LabVIEW User Group Piemonte

Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.

web browser non apre maps

salve a tutti. sono nuovo di questo mondo.stavo creando un VI che mi ricreasse una navigazione internet. ho usato ,dunque, il web browser collegato al metodo navigate2. funziona,ma quando inserisco come indirizzo googlemapsproblema.JPGmi appare questa immagine. ho provato anche ad impostare google chrome come browser del pc, ho anche impostato la compatibilità con internet explorer, ma non funziona. aiutatemi!!!!!

0 Kudos
Message 1 of 3
(4,357 Views)
2 REPLIES

Re: web browser non apre maps

Ciao,

  non sono espertissimo di queste cose, ma prova a dare un occhio a questi link; non so se seguono tutti il tuo metodo di inserire il browser in LabVIEW, ma pare che funzionino!

Google Maps in LabVIEW

https://decibel.ni.com/content/docs/DOC-7983

Using Google Maps in LabVIEW

https://decibel.ni.com/content/docs/DOC-12505

LabVIEW and Google Maps API Interface

https://www.youtube.com/watch?v=A2kpWqhkP9g

Se non trovi la soluzione, chiama il supporto tecnico a Milano allo 02 413091, o scrivi nei thread dell supporto tecnico (ni.com/ask) così vedranno il messaggio molte più persone.

Spero di esserti stato utile, ciao.  Nicola

0 Kudos
Message 2 of 3
(3,973 Views)
Highlighted

Re: web browser non apre maps

Sembra che Google lamenti il fatto che la versione del browser in uso sia obsoleta.

Non si tratta tuttavia del browser che usi come browser di default, ma la versione del browser "embedded" ossia quella utilizzata dai programmi (in questo caso Labview) che ne usano solo il motore... (LabView usa il motore di Internet Explorer).

È possibile cambiare la versione del motore del browser usato da Labview aggiungendo una chiave ai registry del tuo PC.

Trovi una descrizione completa (in inglese) di come fare qui.

In breve: devi aggiungere un DWORD ad una chiave di registro (che dipende dalla versione di Labview, se è una 32 bit o una 64 bit).

La chiave deve avere nome LabVIEW.exe ed un valore che dipende dalla versione del browser che vuoi emulare.

Per Internet Explorer 11, ad esempio, il valore deve essere 11000 (o in esadecimale 00002AF8)

Trovi l'elenco completo dei valori per le diverse versioni di IE qui.

Spero di esserti stato utile.

0 Kudos
Message 3 of 3
(3,973 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.