LabVIEW User Group Munich

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2016 Blockdiagramm Performance

Solved!
Go to solution

Hallo zusammen,

seit geraumer Zeit verwende ich in mehreren neuen Kunden-Projekten LabVIEW 2016. Davor hatte ich zuletzt LabVIEW 2015 benutzt. In LV2015 war es für mich nie ein Thema, Objekte im Blockdiagramm oder FP zu verschieben (u.U. zu kopieren bei gedrückter STRG-Taste), das lief alles zugüg und performant ab. In LV2016 ist das nun anders: Das verschieben/kopieren fühlt sich neuerdings sehr "hakelig" an: Das - wie soll man es ausdrücken - feeling/feedback auf Mouse-Aktionen hat sich aus meiner Sicht erheblich verschlechtert, soweit, daß man teils Objekte gar nicht dorthin bekommt, wo man sie hinhaben möchte. Man beobachtet dabei, daß LabVIEW "mehr macht" als früher: Wires umleiten, Strukturen vergrößern, verkleinern, verschieben usw. ... alles, was ich eigentlich nicht benötige und was meine gewohnte Arbeitsweise erheblich beeinträchtigt (viele Aktionen, die man tausend Mal gemacht hat ohne zu denken, sind ja bereits im Rückenmark abgespeichert).

Meine Frage: Stört das noch jemanden anderen? Kann man diese neuen "Features" von LV2016 evtl. ausschalten?

Ergänzend: LV2015 habe ich auf einem Win7, 32bit-System verwendet, LV2016 verwende ich nun auf einem neuen Win10, 64bit-System (LV32bit) - ich denke aber, daran liegt es nicht, da der neue Rechner ansonsten sehr performant arbeitet. Einen direkten LV-Vergleich auf demselben System habe ich derzeit nicht.

 

Feedback aus der Gruppe würde mich freuen.

VG

Andreas Pfichner

0 Kudos
Message 1 of 5
(461 Views)

Hallo Andreas,

 

ich kann leider zu LV 2016 nicht viel sagen, aber ich kann deine Vermutung bestätigen: An Win 10-64 sollte es nicht liegen. Ich verwende 2015 SP1 mit Windows 10-64 und da läuft alles sehr flüssig.

Sorry, dass ich da nicht mehr helfen kann.

 

Allgemein würde das nur den Trend fortsetzen, dass das Blockdiagramm stetig unperformanter wird. Bei 2012 habe ich noch ziemlich viel mit der Aufräumen Funktion gemacht. Das hat zumindest dann einigermaßen funktioniert, wenn man das 4x2x2x4 Pattern benutzt hat.

In 2015 SP1 hat man da kaum Chancen gute Ergebnisse zu erzielen.



Remember Cunningham's Law
0 Kudos
Message 2 of 5
(460 Views)

Hallo Andreas,
bei uns verwenden auch alle Windows 10 64Bit - daran sollte es also wirklich nicht liegen.

Zwecks Performance: hier habe ich ehrlicherweise keine wirklichen Verschlechterungen wahrnehmen können, allerdings arbeiten wir alle mit i7 und ssd.
In den Optionen hake ich sowieso alles weg was irgendwie "auto" im Text hat 😉

0 Kudos
Message 3 of 5
(454 Views)
Solution
Accepted by topic author Andreas_Pfichner

Hey Andreas,

ich konnte leider auch nichts feststellen - aber ich nutze LabVIEW ja leider auch nicht so intensive ;). Aber ich hab was in der Community gefunden - es gibt den ini token: LiveDrag=False

Mehr dazu hier:

http://forums.ni.com/t5/LabVIEW/Labview-2016-new-improvments-to-selecting-moving-and-resizing/td-p/3...

Einfach mal testen - bin aufs Feedback gespannt.

Grüße aus München

Lorenz

0 Kudos
Message 4 of 5
(446 Views)

Hi Lorenz,

stolpere gerade ins Forum und über Deinen Beitrag - da ich nicht erinnere, ob ich es schon beantwortet habe...: LiveDrag = False hat tatsächlich das von mir beobachtete Verhalten verändert: Das "Feeling" ist nun wieder so, wie ich es gewohnt gewesen bin.

Danke und Grüße

Andreas

0 Kudos
Message 5 of 5
(434 Views)