LabVIEW Real-Time Idea Exchange

About LabVIEW Real-Time Idea Exchange

Have a LabVIEW Real-Time Idea?

  1. Does your idea apply to LabVIEW in general? Get the best feedback by posting it on the original LabVIEW Idea Exchange.
  2. Browse by label or search in the LabVIEW Real-Time Idea Exchange to see if your idea has previously been submitted. If your idea exists be sure to vote for the idea by giving it kudos to indicate your approval!
  3. If your idea has not been submitted click New Idea to submit a product idea to the LabVIEW Real-Time Idea Exchange. Be sure to submit a separate post for each idea.
  4. Watch as the community gives your idea kudos and adds their input.
  5. As NI R&D considers the idea, they will change the idea status.
  6. Give kudos to other ideas that you would like to see in a future version of LabVIEW Real-Time!
Top Authors
Showing results for 
Search instead for 
Did you mean: 

Provide a Virtual Machine (VM) in which to run LV RT systems on

Status: In Development

When developing RT code (especially system upgrades) it would be truly helpful to have a virtual machine (VMware, MS Virtual PC, Sun Virtual box, etc....) that would allow us to run the actual VxWorks OS and LVRT in it's native environment, within the Windows OS. This would allow the code to run on the actual RTOS (I realize that determinism would be scacrificed) and provide the ability to actually test the functionality of the code in the actual environment to ensure that it runs as it should. It would also preclude the need to have a bunch of RT controllers sitting on the shelf in the event that you might need them.


There is and emulator for PDA module, why not for RT.

Proven Zealot

Awesome and kudo given.  I just followed the steps and it worked as you described.  The only thing I couldn't figure out how to do is enable the Embedded UI.  Once I installed the LabVIEW runtime and restarted that option still wasn't there in MAX.  How did you install the UI environment?


I tested earlier and the UI option appears when I install Realtime 2017. The option doesn't appear when I used 2019. I didn't test 2018. 


I intend to do additional testing next week.


The strange thing is when you use 2017 it shows as virtual box for the model however on 2019 it shows as a cRIO with a serial number. 

Certified LabVIEW Architect, Certified Professional Instructor



That's just awesome. That's so much easier.

Incredible, thanks a lot.


A - Same UI comportement here with 2019 : xserver is disabled in the target's conf.


1 - To activate it, type these commands :




2 - After a short funny touchscreen configuration sequence, you'll get a desktop :Xfce-Lv2019.png



B - About the keyboard : in my case, I couldn't deal with the keyboard step.

So here's an alternative way if people have the same issue :


1 - Type F12 when the VM is starting -> the EFI boot screen is showing and give you the keyboard back. Select "Continue" :



2 - At the "Verbose menu" step, type "e" to edit the grub line command like this (the restore parameter call the shadow script named "backward-migrate") :



3 - Type F10 to boot, and wait the auto-install to complete.


C - The Env variables... Even the Network Variable Engine can be deploy to the target... Don't believe it.

Curiously, partitioning has not changed much, interesting.


That's brilliant saves me doing the testing next week. Glad the UI works in 2019 as well. 


I was sure you could put something into the grub edit however I had no idea what thank you for sharing the solition. 

Certified LabVIEW Architect, Certified Professional Instructor



Just tested out the extra steps written by fmorandat and I can confirm the UI works in 2019 it even persists after a reboot. It however dosent show the option to enable in NI Max

Enable UI Switch MissingEnable UI Switch Missing

Commands listed out if you want to copy paste.

/usr/local/natinst/bin/nirtcfg --set section=SYSTEMSETTINGS,token=ui.enabled,value=True

I found that if I reboot the VM after running the above the UI would launch correctly after reboot. If I forced it to start using the below command it would cause it to become unstable. I couldn't open the terminal for example. 

/ect/init.d/xserver-xfce start

However these could issues limited to my install.

Certified LabVIEW Architect, Certified Professional Instructor



Oops wrong post, do not know how to delete


Active Participant

Hi all,


Just tried to find the iso files, but nothing.


Which exact package installs these?

My list:

sw list.PNG

My dir listing:

dir list.PNG

André (CLA, CLED)

From what I know, it comes with the LabVIEW 2019 Real-Time Module and/or the lastest version of MAX.


It's the iso presented here :

Active Participant

Maybe I haven't got the PXI stuff installed, I only used cRIO RT controllers.

André (CLA, CLED)


To see the differences with my conf : I use LabVIEW 32 bits, and, true, all the NI PXI Platform Services are in 19.0.0 :



Also, I have the Real-Time support for PXI Platform Services in the installed Drivers section of NIPM :