LabVIEW Real-Time Idea Exchange

About LabVIEW Real-Time Idea Exchange

Have a LabVIEW Real-Time Idea?

  1. Does your idea apply to LabVIEW in general? Get the best feedback by posting it on the original LabVIEW Idea Exchange.
  2. Browse by label or search in the LabVIEW Real-Time Idea Exchange to see if your idea has previously been submitted. If your idea exists be sure to vote for the idea by giving it kudos to indicate your approval!
  3. If your idea has not been submitted click New Idea to submit a product idea to the LabVIEW Real-Time Idea Exchange. Be sure to submit a separate post for each idea.
  4. Watch as the community gives your idea kudos and adds their input.
  5. As NI R&D considers the idea, they will change the idea status.
  6. Give kudos to other ideas that you would like to see in a future version of LabVIEW Real-Time!
Top Authors
cancel
Showing results for 
Search instead for 
Did you mean: 
gsussman

Provide a Virtual Machine (VM) in which to run LV RT systems on

Status: In Development

When developing RT code (especially system upgrades) it would be truly helpful to have a virtual machine (VMware, MS Virtual PC, Sun Virtual box, etc....) that would allow us to run the actual VxWorks OS and LVRT in it's native environment, within the Windows OS. This would allow the code to run on the actual RTOS (I realize that determinism would be scacrificed) and provide the ability to actually test the functionality of the code in the actual environment to ensure that it runs as it should. It would also preclude the need to have a bunch of RT controllers sitting on the shelf in the event that you might need them.

 

There is and emulator for PDA module, why not for RT.

69 Comments
andre.buurman@carya
Active Participant

Use instructions in section B of https://forums.ni.com/t5/LabVIEW-Real-Time-Idea-Exchange/Provide-a-Virtual-Machine-VM-in-which-to-ru...

 

If you get into the window where 2 boot options verbose and non-verbose, don't choose anything, but press e

 

Then the screen shown in B2 should appear and the change the grub parameters to match.

Regards,
André (CLA, CLED)
djac91
Member

That worked. Thanks

-----------------------------------------------------------------------------------------------------------------------------
Waiting For the inner calling 🙂


djac91
Member

It shows up as a compactRIO device under remote systems in MAX. How can I change it to a PXI controller instead

-----------------------------------------------------------------------------------------------------------------------------
Waiting For the inner calling 🙂


fmorandat
Member

Hi djac91,

 

I'm quite busy this week, but I hope it will help you anyway.

 

To change the kind of target, it's necessary to edit the fields DeviceCode and TargetClass of the file /boot/grub/grubenv.

 

To edit this file, checking this post can help you :
https://forums.ni.com/t5/LabVIEW-Real-Time-Idea-Exchange/Provide-a-Virtual-Machine-VM-in-which-to-ru...

 

For a PXI target :
- the value of TargetClass is "PXI" (without the "").
- and for the DeviceCode, 0x77E1 will fit.

 

So, the commands will be :

  • grub-editenv - set TargetClass=PXI
  • grub-editenv - set DeviceCode=0x77E1

 

- In the today's NXG 5.0, it will be recognized as a 8840.
(For the RT version, it seems you can switch to it via the SystemDesigner -I still discover).

- I didn't test the VM in LabVIEW 2020 yet.

 

About using NI's VM for other targets : Dan is right, preferabily use supported targets by greeNI, depending on LabVIEW version you want to use. NXG or standard.
Otherwise it can oddly brings a kind of confusion -if there is one.

 

Regards.


(A complete post/white paper for current installation would be useful, isn't it ?)

nwxan90
Member

I have written out the full instructions I just want to do some more testing with 2020 next week before I publish them. 

I will share a link to them once I have them written as we have learned a lot since we started experimenting in this thread. 


Certified LabVIEW Architect, Certified Professional Instructor

CLA CPI

zundap1970
Member

Hi all a try to repeat the procedure described in this thread but...without the same result 😞

First of all I don't have a NI Linux *.iso file for cRIO so I used "standard_x64_recovery.iso" file from NI package manager (via ni-linux-rt-pxi-system-image-2019.09_19.5_online_repack2.exe)

After that I create the VM with settings :

2048 MB RAM, 10 GB HD, EFI on, Ethernet board as only host and controller USB 3.o (xHCI) selected.

The VM is based on Oracle VM 6.1 + Oracle_VM_VirtualBox_Extension_Pack-6.1.12.vbox-extpack 

 

run the VM, select the *.iso file and the verbose mode but the installation is blocket at :

 

 

7.jpg

 

and the keyboard doesn't work.

First of all...someone has suggestion about how to skip this problem?

Someone can indicate where is possible found RTOS for cRIO target? The file used seems for pxi

fmorandat
Member

Hi zundap,

I don't know where this "repack exe" comes from (the lasts iso files are made for cRIO), but if nothing changed you can find a help for the keyboard on the post of André, 5 posts upper.

Try that first, then use recents posts of nwxan90 (at least p.4) to change the target type.

PM me if you need.

Taggart
Active Participant

Using VMware, 

 

on first boot appears to be hanging here. any ideas?

Screenshot from 2021-01-24 10-32-35.png

Nevermind. Figured it out. Missed the UEFI setting. I'll leave this up in case someone else runs into the same thing.

Sam Taggart
CLA, CPI, CTD, LabVIEW Champion
DQMH Trusted Advisor
Read about my thoughts on Software Development at sasworkshops.com/blog
GCentral
Taggart
Active Participant

I did a write up of my experience doing this in VMware here. It takes most of the information here and condense it into one spot. Thank you all for sharing all your knowledge.

https://www.sasworkshops.com/how-to-create-a-crio-virtual-machine/

Sam Taggart
CLA, CPI, CTD, LabVIEW Champion
DQMH Trusted Advisor
Read about my thoughts on Software Development at sasworkshops.com/blog
GCentral