LabVIEW Project Providers

Showing results for 
Search instead for 
Did you mean: 

Apply Icon To VIs node crashes LabVIEW 2011 in Provider Context

I am experiencing an issue with Apply Icon To VIs node for a Class Library (use case).


Running this node in the Provider Context crashes LabVIEW on my PC (Win 7 x64).

I have uploaded code that is stripped back to illustrate the issue.


  1. Download and unzip Test Code
  2. Merge Providers folder with <resource>\Framework\Providers
  3. Restart LabVIEW
  4. Open the project in Test Folder
  5. Right-click on Class and select LVOOP Assistant >> Rename LVOOP Labels

right click.png

Also, here is a screen capture: of what I am seeing.

Does anyone else get the same issue (I can currently only test on 1 PC)

This node works fine e.g. calling from the Tools Meny (whatever that app context is?).



[Code in LabVIEW 2011]

Certified LabVIEW Architect * LabVIEW Champion
0 Kudos
Message 1 of 6

Same results for me on my Win 7 x64 PC with LabVIEW 2011 32-bit.  I haven't confirmed that it does not crash when run in the regular context since running the Item_OnCommand VI without a valid Object ID just errors out.  Would have to do more testing to make sure it's a provider-specific crash or just this invoke node that is crashing. 

However using breakpoints and execution highlighting in the provider context shows that it's definitely hanging on that node.  I will do more experimentation and post back...


Message 2 of 6

The code works in the regular context and also when called from the Tools >> menu (whatever that context is called?).

I haven't tried yet - but I am thinking a workaround maybe to just open a reference in the regular context by name (as the Class is in memory) and then run the Apply Icons node.

Certified LabVIEW Architect * LabVIEW Champion
0 Kudos
Message 3 of 6

Definitely looks like just a bug.  I have filed CAR 334739 about the issue.  Looking at workarounds now...

0 Kudos
Message 4 of 6

Tried a couple of workarounds with David. This one seems to work:



Sumedha Ganjoo | LabVIEW R&D
0 Kudos
Message 5 of 6

Cheers for the code guys.

Unfortunatley I cannot get it to work as it just replaces the VI Icon with that of the Class Icon, overwriting the other VI Icon Layers.

I have managed to come up with a workaround, needs more testing, but seems to do what I need it too at the mo - attached is the code.

(I actually like this as if I refactor the code I can update a refresh a single VI icon, rather than the entire Class - for another project ).


Additionally this functionality is avialable from the Class\Library Preferences Dialog:


<resource>\Framework\Providers\VILibrary\ calls this node and runs from the Provider and it works (does it run in the Provider context?).


Maybe poking around here would lead to another workaround/idea?- Although its all locked out for me


[Code in LabVIEW 2011]

Certified LabVIEW Architect * LabVIEW Champion
0 Kudos
Message 6 of 6