LabVIEW Interface for Arduino Discussions

Showing results for 
Search instead for 
Did you mean: 

can not upload the fireware of the lavbiew interface to arduino

Another solution is to open up the block diagram of the Arduino Analog Read example and add a constant to the VISA resource input of the Arduino Init which specifies which COM port the Arduino is connected to.  Take a lo look at the following image to see what that would look like:


Kevin Fort
Principal Software Engineer
0 Kudos
Message 11 of 15

Hi JH,

I tried Solution 1 :

Picture 3.png

Changed the name "Arduino" to "Communications Port", and ran that block... I don't really know what this is for, but the Panel showed two checkmarks where there was once one:

Picture 4.png

...but I had to changed that "Visa Resource" to USB each time I ran it - seems it's not the default... this is what the panel looks like if I don't change to :USB"

Picture 5.png

So I gather I need to, as Kevin_F suggests, add a constant to ensure that the correct port is selected when trying to run the Arduino Analog Read I will try this next, but I think I might be in a little deep here - Labview in it's structure is so different from HMI's found in the Industrial setting, I really have no frame of reference. In those HMI's, there is always some sort of IO database configuration, and a place to setup drivers (sometimes in the same database). I will keep trying because I think I am close.

0 Kudos
Message 12 of 15

Christmas miracle guys!!!

Picture 6.png

What I did (without knowing what I was doing) was to copy and paste that VISA resource pulldown box you see in the bottom left, from the Auto Detect vi, to the analog read vi. I gather anything OUTSIDE of the box is initialization or exit code... so this allows me to configure the IO before I hit the play button... still haven't figured out how to just make this a constant, but at least I can play now!

0 Kudos
Message 13 of 15

Let us be generous - PFA for BYTE replaced

0 Kudos
Message 14 of 15

Just today I received my first Arduino and immediately ran into this problem, and its resolution described here. Thanks to all, this seems to be a very helpful community!

I had also the apparent problem that the Arduino wasn't detected; playing with NI-VISA-Configuration helped me to identify the correct ressource. I add a screenshot with all relevant settings, hopefully this helps better than 1000 words.

Happy New Year to all!


0 Kudos
Message 15 of 15