LabVIEW Interface for Arduino Blog

Community Browser
Showing results for 
Search instead for 
Did you mean: 
1 Comment

Hello every one, i don't know if it's the good place to post my question. If it's not just tell me where i have to ask it.


I have an arduino connected to my laptop, i upload the firmware of lifa on my arduino and i have no problem to communicate with my arduino from labview.

My goal is the following :

I  want to receive data from an other arduino (i will name it A2) with a wireless communication. So i bought an Nrf24l01+ which allows me to communicate between my two arduino. I will receive data from many different sensor (actually only two: an IMU gy-521 and some distance sensor hrs04) providing by A2 to A1 with my wireless module.

BUT i don't know how to program that on labview, and moreover, i don't know if it's possible to program that on labview. There is no help on the huge spider web so i come to you hopping that you will light my mind.

How am i suppose to handdle it ? Do i have to set up some other librairies on labview or arduino, what should i do?

Thanks for helping me everyone, i hope i make myself clear, if you have any further question for better answering me i will answer as quickly as possible.

Thanks anyway, yours faithfully.


Hi im using the arduino uno and altimu-10 v4 to create an AHRS with graphical display indicators.

Ive attached the block diagram to my program. I cant seem to make it work. Please help me out. Im new to this labview


Dear Friends 

i am starting  a project in which a basic PMDC motor with a 2PPR magnetic encoder controlled with a arduino MEGA and a Cytron motor shield MD10 driver i want to control it with the Lab view for basic position control. As i understand LIFA is the interface to be used and LINX also would be an option would it be possible to control it as i intend to control the position of the motor CW and CCW upto a certian degre which will be controlled with the encoder and the program to be built in the LabView.

The type of program i am trying to build up is that the motor goes upto a certain angle CW and then halts due to encoder with an interrupt feedback and then goes CCW upto the required angle.and then interrupt stops and then go to home position given by IR sensor.

I am a beginner with arduino and labview will this logic be possible as mentioned above or will it have a lot of lapses in counting and operation.

The hard ware i have available is mentioned below with specs

Motor: 2RPM 24VDC 2A 56Nm torque 1/720 ratio

Encoder: Magnetic 2ppr on motor.

Driver: Cytron motor shield MD10 (How about a SYREN10 driver, Arduino and Labview have serial comunication & so does the SYREN10 driver will that help prevent miscounts from encoder)

Arduino mega board

My only concern is the torque required i dont want to control speed or any other factor. I would appreciate your feedback, please inform me if any further info is required .

Your feedback will be appriciated.



I'm trying to control a stepper motor using arduino and labview. When I try to initialize the arduino on labview it gives the following error 5002: Unable to establish connection with Arduino.  Please ensure that you have selected the correct COM port and that you have flashed the Arduino with the correct firmware.

I used the maker hub firmware for the arduino and even used a simple led example form maker hub also and it work well.

I wrote a program using arduino software alone and stepper motor works. When I used the program example on labview is when the error occurs. Also I try to lowered the Baud rate because in NI-Max it says 9600 (default 115200) and also the bit package to 8 (default 15).

I checked the COM in Ni-Max and is the same number in device manager.

I'm using labview 2012, on win 7/ 64bit. Ni visa 14.01


What might be producing this error any ideas? If you need any extra information I will reply as soon as I can.

Thanks in advance.



i am making a project 'energy management using wireless control' and for that i am using arduino mega2560 as TX and arduino UNO as RX , RF24 as transceiver and monitoring data in labview now i want to control devices from labview which are connected to arduino mega2560 so that devices can be controlled wirelessly .Is there method for doing that.? i just want an idea...

Thanks in Advance.

1 Comment

i want to add arduino input....when '1' come,labview add it with second '1' and becomes 2 ,3,4 and so on..


Hi every body,

I try to find a way for install Labview Interface for Arduino (LIFA) without vi package manager as an easy second way!

Now i like to share a guide about how can easily do it!

All steps noted in note file in shared .rar file.

Have a good time.


Hi good afternoon, I am trying to make an interface for reading load cells, I am using a digital analog converter SPI protocol variant with two wires. what I want is to display the output signal ads1230 mind binary and back view in kg or lb. I hope you can help me.

I leave the ads1230 data sheet:

user's guide:


1 Comment

Dear friends,

I have completed successfully my mini project titled 'water level indicator' ,this forum helped me a lot, thank to all around globe  for your most valuable posts,

I have faced many problems during my project,only this forum helped me.

Thanking you,


Krishnakumar subramaniam


Hello Guys,

We have a project and we are working with URM37 v.4 ultrasonic sensor. We are finding many problems while writing the code, so I want to ask you if anyone worked with this type before and if you can help us with a labview code.


1 Comment

i opened LIFA_BASE.ino on Arduino 1.6.0 but it didnt compile and message occured !!

Arduino: 1.6.0 (Windows 7), Board: "Arduino Uno"

C:\Program Files (x86)\Arduino\libraries\RobotIRremote\src\IRremoteTools.cpp:5:16: error: 'TKD2' was not declared in this scope

int RECV_PIN = TKD2; // the pin the IR receiver is connected to


Error compiling.

  This report would have more information with

  "Show verbose output during compilation"

  enabled in File > Preferences.

what should i do ??


So, I have the Arduino software 1.0.5 (1.6.0 will not upload LIFA to my arduino uno) and it can upload the blink example and the LIFA to the arduino uno.  It all seems fine up to here.  Then I try to run one of the VIs or just initiatlize the arduino uno with the arduino labview drivers and I get that darn 5002 error.  I have checked everything and reinstalled everything, so I am not sure what to do next to try to get the arduino working with labview.  Any thoughts?  Do you have to do anything with NI-MAX? 


Have you see these low-cost robots for Arduino!

Great way to learn and have lots of fun, too!


I am a student.I am studying mechanical engineering .I am doing a project  But I have  knowledge about LabVIEW little.I've been programming  LabVIEW  on the light IC BH1705 sensor.I donot know  coding for the program with the light IC BH1750 sensor.Help me please

1 Comment

The open source revolution certainly has taken the world by storm. What started as something that could be pegged as something to be used by Academia only and as utopia in the cut throat commercial world in the early seventies is now a reality. It has changed the way our kids learn, the speed technology evolves, the level of accessibility less privileged individuals have to technology, and so many other aspects that some are now linking the open source movement with the very fabric of how companies will function and, why not to say, how society will live.  

It is impossible to say open source without immediately thinking Linux. The Unix-based operating system that was created by a student in 1991 - again Academia helping shape our future - is now almost as popular as the one day single ruler Microsoft Windows. For the ones with their fingers kept close in the pulse of the evolution of the Software development community, many more examples come to mind, such as; MySQL for databases, Apache for server software, Python for general scripting programming, PHP for web design and many others.

Historically, open source has been always correlated to Software. However, the community produced an aftershock of the first movement that has been as unexpected and formidable as the original one; the Hardware open source movement. The hardware open source movement, in its core, carries the same philosophy as its older brother: all artifacts produced are open and disclosed. In the Hardware world, that means schematics, bill of materials, mechanical model files, printed circuit board layout files, even manufacturing ready gerber sets are made available to the community.

There are several popular open source hardware projects; such as Raspberry Pi and Arduino. Some others are new kids on this block but are none less coming out strong, such as UDOO and Red Pitaya. In my opinion though, Arduino is for the Hardware open source movement what Linux was for the Software one. Arduino was the precursor of so many other projects of the same nature that an impressive critical mass was generated by the Hardware community around these types of projects. Arduino has now been slowly but surely migrating beyond the hobbyist audience, into the professional industrial one. 

Together; they are bringing about what some people are calling the next industrial revolution. Is this comparison an exaggeration? I sincerely don’t think it is. In order to make a case for the acceptance of this association between the original industrial revolution and the current open source movement, let’s take a quick trip back in time to evaluate, in the high level, the 1800s industrial revolution.

Back then, the main focus was to bring about change via increased efficiency of the industrial production. Henry Ford was certainly one of the great minds of that era, who made available the Ford production line concept; which is still an inspiration in today’s industrial settings with its concepts of lean manufacturing and 5S. Ford is probably the first name that comes to people’s mind from the industrial revolution movement. However, I offer that Ford wasn’t thinking much differently than all the other minds who were preoccupied with the obsession of transforming the way industries worked. The holly grail of that historic moment was to produce more with the same resources that were utilized to produce much less. Underneath it all; it was all about making things available to different levels of society. It was about creating different consumer markets; to create wealth. It was about having the ability to making cars; citing Ford again, available to the middle class in addition to the rich minority. All technological innovations of the time were centered on this very goal. That is how the steam engine was invented and propelled this concept into reality. The root concept was to make things; starting with consumable things but then later expanded to other things, available to the masses.

How is this different than what the maker’s movement is aiming at? Today’s obsession is very close to the industrial revolution one: it is also about making available to the masses what wasn’t available until then. Since technology is usually a big driver, if not the biggest one, to how we live our lives – e.g. facebook, tweeter and, why not to say, the Internet itself – making technology available to the masses will most likely shape our future’s reality a little differently than it is forged today. Having a microcontroller based hardware board available for around $20 – named the Arduino platform, just to cite one – has been putting and will continue to put technology in the hands of a larger and larger critical mass of people. This movement has given non-profit organizations and social movements, such as, the right to dream about actually having a shot at changing our kid’s and kid’s kids realities through technology. Let’s teach them how to fish instead of the futile attempt to give them the fish. Let’s develop productive members for our society through technology as opposed to complacently accept the reality that almost 15% of Americans live in a state of extreme poverty. And this is America, the richest and most powerful nation of the globe. I am embarrassed to even state statistics about Africa and South America.

The Arduino Compiler for LabVIEW is my small, infinitesimal even, contribution to this movement. I would like to see the test and measurements industry become more and more part of the new industrial revolution. Test is a fundamental aspect of every product; and, in order to make products more and more available to lower income individuals, test and measurements needs to get with the program. It needs to offer alternatives, low cost ones, so test Engineers can do their jobs in the most economical way possible.

Let’s take advantage of the maker’s movement machine that has started moving and give our own contributions to it. If every one of us offer ideas and use our skills in benefit of the biggest brotherhood of all, the human race, wealth will not only seek and find us, but it will also extend its graceful hands to our brothers and sisters. We can transform this world of inequalities into one much more leveled, where all of us could be free to explore our full potentials.

1 Comment

Anyone having issues with the lifabase sketch in Arduino IDE 1.0.5? I used it a few months ago then came back to install it on a different Arduino and now for some reason it won't compile. I tried uninstalling the Arduino for labview package from VI Package manager, then reinstalling and got the same errors.

Here is the errors:

C:\Users\Joshua\Documents\Arduino\libraries\LiquidCrystal/LiquidCrystal.h: In function 'void processCommand(unsigned char*)':
C:\Users\Joshua\Documents\Arduino\libraries\LiquidCrystal/LiquidCrystal.h:136: error: 'void LiquidCrystal::init(uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t, uint8_t)' is private
LabVIEWInterface:362: error: within this context

Any help would be greatly appreciated.



I followed the install procedure but the VIPM does not find the LV runtime installed.

Is the student version required, as the minimum install?




I am currently trying to use the arduino leoardo to interface with the labview but when downloading the firmware file on to the board it says error in the code.

Can somebody please help??


I have install LIFA and also LINX. I tried to upload LIFA to my Uno board, but there is some error I found.

Arduino: 1.5.6-r2 (Windows 7), Board: "Arduino Uno"

C:\Program Files (x86)\Arduino\libraries\RobotIRremote\src\IRremoteTools.cpp:5: error: 'TKD2' was not declared in this scope

  This report would have more information with

  "Show verbose output during compilation"

  enabled in File > Preferences.

How can I fix this problem?




Hi Forum,

i am using a Adruino to display my state form the labview application. I would like to use the Adruino also for other tasks like a 12V relay or temperature measurment. Is there a way to use multible adruino tasks in the same vi? Displaying informations on the lcd screen works fine but i cant use mulible tasks with the adruino.




In my notebook is not compiling the LIFA_BASE what should i do?

Is possible that  the problem is with the new version of arduino software?



Buenas tardes

Tengo un problema para iniciar la utilizacion de LIFA por q no me deja cargar el archivo en la placa arduino UNO.

Al compliar el archivo me sale el siguiente error:

IRremoteTools.cpp:5: error: 'TKD2' was not declared in this scope


Me gustaria que me colaboraran para solucionar este problema lo antes posible.

Mucas gracias

Espero pronta respuesta.


Hello my problem is that. I am able to control only one led and the other one, i am not able to control it.

can somebody help me what is the problem with the VI. My lifa is ok since the first led is working

perfectly fine when i am pressing the on / off button in labview. I will really appreciate to get answer

for this problem of mine.


I'm from Brazil, and I need your help!
I started to work with interface Labview/ arduino mega2560, and I can't  deploy Lifa- base code to arduino!
my software version is:
LabVIEW 2011;
id-arduino 1.5.6-r2;

Could someone help me?

thank you...


hello please Help.

I have a arduino NANA v3 it will not work with labview

i download the driver

NI LabVIEW Interface for Arduino Toolkit

and it don't work with NANO

Please help me


hello please Help.

I have a arduino NANA v3 it will not work with labview

i download the driver

NI LabVIEW Interface for Arduino Toolkit

and it don't work with NANO

Please help me


I am doing a project for school to control a DC motor using an Arduino Uno card. I want to know if it is possible to modulate the voltage output on any of the pins. What I would like to try to do is connect a dial input from the front panel that would allow me to increase and decrease the voltage to the motor. When testing the Arduino card I found that I get 5 volts out however my motor is rated at 1.5-3 volts. So I would like to be able to reduce the amount of voltage and be able to adjust it from the front panel. Can anyone help me do this?


while compiling LIFA Base in arduino IDE , I am getting below error

Arduino: 1.5.5 (Windows 7), Board: "Arduino Uno"

C:\Program Files\Arduino\libraries\RobotIRremote\src\IRremoteTools.cpp:5: error: 'TKD2' was not declared in this scope

This report would have more information with

"Show verbose output during compilation"

enabled in File > Preferences.

can any one help me to get out of this error