LabVIEW Interface for Arduino Blog

Community Browser
Labels
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Problem with upload LIFA to UNO, Need Help!

Member

I have install LIFA and also LINX. I tried to upload LIFA to my Uno board, but there is some error I found.

Arduino: 1.5.6-r2 (Windows 7), Board: "Arduino Uno"

C:\Program Files (x86)\Arduino\libraries\RobotIRremote\src\IRremoteTools.cpp:5: error: 'TKD2' was not declared in this scope

  This report would have more information with

  "Show verbose output during compilation"

  enabled in File > Preferences.

How can I fix this problem?

Thank,

Theerapong

Comments
Active Participant

For LIFA you need to use version 1.0.5 of the Arduino software. Sammy has said in the past LIFA is designed to work with version 1.0.5 and he is not supporting LIFA or LINX on Beta versions of the Arduino sofware.

hrh1818

Member

Thank you for help.
I have downgrade the IDE version to 1.0.5 and it works.
But, another problem is coming.
Labview cannot detect the Arduino board. So, I couldn't assign  the comunication port.

Member

i have the same problem with arduino 1.6 !!!