LabVIEW Idea Exchange

About LabVIEW Idea Exchange

Have a LabVIEW Idea?

  1. Browse by label or search in the LabVIEW Idea Exchange to see if your idea has previously been submitted. If your idea exists be sure to vote for the idea by giving it kudos to indicate your approval!
  2. If your idea has not been submitted click Post New Idea to submit a product idea to the LabVIEW Idea Exchange. Be sure to submit a separate post for each idea.
  3. Watch as the community gives your idea kudos and adds their input.
  4. As NI R&D considers the idea, they will change the idea status.
  5. Give kudos to other ideas that you would like to see in a future version of LabVIEW!
cancel
Showing results for 
Search instead for 
Did you mean: 
leon42

Text editing with ctrl + arrow keys

Status: Declined

I've moved this issue to Bug 1341237. However, it isn't being prioritized for a fix at this time because we believe the configurations that have this problem aren't common and that using "English (United States)" as your format locale is a reasonable workaround.

When I try to select a word or more words I currently have two options. The first one is to hold down shift and select on letter by letter basis which is slow. The second one is to select with help of mouse, which is error prone.

 

Normally all text editors have options to move for 1 word left or right by ctrl + left arrow or ctrl + right arrow. The same goes for selecting a word (ctrl + shift + arrow). I would like this functionality to be supported by LabVIEW at least on block diagram, VI documentation, enum editing.

7 Comments
Its_Me_Ashiq(ஆஷிக்)
Member

This feature is already present at-least from LabVIEW 2015.

 

I couldn't even find any property to Enable/Disable it (as we do for QuickBold in LabVIEW.ini file).

 

It seems like a default feature in there!!!

 

LabVIEW Text Editing Feature.mp4 

 


leon42
Member

It does not work for me in same way as it works for you.

 

I have tried this on my computer and one other computer. On mine it does not work, but on the other computer it does. The difference between the computers is the setting in Region -> Format. If I choose English(United States) or English(United Kingdom) the ctrl + left works. If I choose either English(Slovenia) or just Slovenia, it does not work. If I choose English(Germany) it also does not work.

 

I think this setting should not interfere with the shortcut.

 

And this raises an additional question. What other settings / configurations are dependent on your system locale in LabVIEW 😟

Its_Me_Ashiq(ஆஷிக்)
Member

@leon42 wrote:

I have tried this on my computer and one other computer. On mine it does not work, but on the other computer it does. The difference between the computers is the setting in Region -> Format. If I choose English(United States) or English(United Kingdom) the ctrl + left works. If I choose either English(Slovenia) or just Slovenia, it does not work. If I choose English(Germany) it also does not work.


Then I'am giving Kudos to get this feature for all the users.


Babel
Member

@leon42 , my LabVIEW R&D colleagues brought this to my attention. However, I cannot reproduce your issue.  I tried switching my regional settings (user locale) to English (Slovenia), also switched my keyboard layout to that country, but the keyboard shortcuts to fast select word by word still work for me.  The only thing our documentation states is that the behavior is different when dealing with double byte chars (Asian languages).  I will ask my Localization QA engineers colleagues if they have any more luck reproducing this issue.

Quick questions for you:   Does it work in other apps like Notepad?  Could "Sticky keys" be somehow turned on?  Could any other application or driver somehow conflict with these shortcut keys?  What version of Windows are you on?  Have you seen this on multiple machines, or just one?

 

Thank you.

Babel
Member

I was able to reproduce the issue when "Language for non Unicode programs", a.k.a.  the System Locale or Windows Code Page is set to Slovenia (code page 1250)  AND the format settings configured to English (Slovenia).  If either one is set differently, then the feature works. 



Babel_0-1614016106208.png

AND 

Babel_1-1614016140459.png


Now that this is understood, I will report the findings to the development team.  Your report will probably be turned into a bug rather than a new idea.   Thank you for reporting it.

leon42
Member

I am glad to help. I guess Slovenian is not the only problem here.

 

Looking forward to the fix. Cheers.

Christina_R
Active Participant
Status changed to: Declined

I've moved this issue to Bug 1341237. However, it isn't being prioritized for a fix at this time because we believe the configurations that have this problem aren't common and that using "English (United States)" as your format locale is a reasonable workaround.


Christina Rogers
Product Owner, LabVIEW R&D