LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 

appending text file with arm processor does not work with offset

I have a labview vi that opens a text file and appends text to it. However it does not start writing at the eof but rather some bytes before the eof. This works fine with the set file position function in labview when I run the vi on my pc. However, on an embedded ARM processor this no longer happens. I still get the text written, but the offset variable is completely ignored.

I write to the same sd card in both cases so it shouldn't be the format issue of the card. Is there some unknown restriction from the ARM processor for writing that I am not aware about?

0 Kudos
Message 1 of 2
(4,392 Views)

Hi mugetsu,

 

The behavior you describe is a known issue that is documented in Corrective Action Report 381541 due to the function fseek() not working correctly when a file is closed and re-opened. Currently we suggest:

 

1. Read file contents into memory, modify the data, then write/overwrite all of this data to file
2. Avoid closing the file reference (if possible)

 

 

Aldo A
Applications Engineer
National Instruments
0 Kudos
Message 2 of 2
(4,367 Views)