LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 

Read data from GPS receiver

Hello! I have two cycles. the first cycle of "fast" (50 Hz), the second cycle of "slow". I want to use the rapid cycle of data from the GPS receiver. But in this version I get a delay in the fast cycle (see 1). Why is this and how to get rid of? PS if you put "milliseconds to White," more than 300 ms, the data from the GPS receiver will be made smaller.Безымянный.jpg

Message 1 of 13
(5,846 Views)

my microcontroller Lm3S8962

0 Kudos
Message 2 of 13
(5,838 Views)

Hi Sergiv,

 

First of all, without the full application you have made, nobody can predict how the code will run..

As far as I can see, the "slow" loop is waiting the most of the time on the GPS data. The GPS data will be generated by the GPS receiver once a time per second. Since your "slow" loop is waiting for 300 bytes, the "fast" loop will run at full speed.

once the GPS data is available (and 300 bytes are available in the serial port), the "slow" loop will process the GPS data.

I think in that case the "fast" loop doesn't run and after the GPS data is processed, the "fast" loop will get it's execution time again.

that why you see the high delay each (second) time I think.

 

try using timed loops and disable parallel execution in the build specificationin your project.

 

Good luck with your project.

 

Wouter

Wouter.
"LabVIEW for ARM guru and bug destroyer"
Message 3 of 13
(5,827 Views)
Thanks for the reply, but I got an error: http://forums.ni.com/t5/LabVIEW-Embedded/bd-p/420
0 Kudos
Message 4 of 13
(5,819 Views)

Hey Sergiv,

 

Would you please post the picture in the same thread?

 

I am confused about your statement along with your post about the error. You say that “Debug on TCP. USB jtag work correctly.” You will need to use the USB JTAG to connect and push code to your board.

 

The error you are getting is just a generic error. Are you able to deploy any piece of code or is there only one particular VI that causes this error?

 

Let us know.

 

Joe S

Applications Engineer

National Instruments

 

0 Kudos
Message 5 of 13
(5,810 Views)

Hi Joe Steak,

 Here is my screenshot\

 

Безымянный.jpg 

0 Kudos
Message 6 of 13
(5,802 Views)

I think that he means that he has changed the debugging mode in the build specification from USB ULINK2 JTAG to TCP port.

I never use debugging in LabVIEW because I think it's not very usefull, but I think there's something wrong with the TCP port.

 

But why do you want to use TCP port debugging instead of the normal JTAG?

Wouter.
"LabVIEW for ARM guru and bug destroyer"
0 Kudos
Message 7 of 13
(5,787 Views)
with TCP is faster than the JTAG. I tried to run the game Ping-Pong (an example) to debug through the TCP. worked without error
0 Kudos
Message 8 of 13
(5,785 Views)

Try forcing the project to rebuild (select "Rebuild All").  JTAG debugging inserts some startup synchronization code that may still be present, thus hanging (ie. target is expecting JTAG while host is doing TCP).

Message 9 of 13
(5,772 Views)
Many thanks for the tip! Be sure to try!
0 Kudos
Message 10 of 13
(5,766 Views)