LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

RT Application freezing after upgrade

Solved!
Go to solution
Highlighted

Hello people,

I would like some help from you.

I've been developing an application for CompactRIO (Linux RT)  using Actor Framework.

Currently, I've been using LabVIEW 2015 SP1.

For a couple of days, I've tried to upgrade my project to the version 2018.

I did all the expected routine: formatted, installed new software, recompiled application and FPGA.

Then when I set to run, the application freezes, it uses all the memory and the cRIO becomes unavailable.

As far as I know, it is something with the application, but it reports no errors, it compiles and everything. I've tried to disable some actors, but so far nothing.

Prior to that, the application was running very fine in 2015 SP1.

Could someone point me where to look in the system (logs, etc...) and maybe find this incompatibility in my code?

Thanks.

 

 

0 Kudos
Message 1 of 4
(1,005 Views)

Hey Felipe,

 

My first guess would be mass compile your entire project.

 

Could you give it a try and then deploy your project one more time?

 

Cheers,

Felipe Flores
Applications Engineer II
National Instruments Brazil



0 Kudos
Message 2 of 4
(972 Views)

Thank you for the hint Felipe, but it was the first thing I did.

Unfortunately, it did not work, but I'll keep looking into this.

Regards,

 

0 Kudos
Message 3 of 4
(958 Views)
Solution
Accepted by topic author felipe.foz
10-16-2018 05:15 AM

After changing some classes that were implemented by-ref to by-value I was able to upgrade without having freezing episodes.

Thanks.

0 Kudos
Message 4 of 4
(791 Views)