LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 

Question about RTTarget.LaunchAppAtBoot in ni-rt.ini

Solved!
Go to solution

Hello,

 

I'm developing an application on a sbRIO. Sometimes I want to disable the RT APP by setting RTTarget.LaunchAppAtBoot=False in the ni-rt.ini, so I can test in the development enviroment and use FPGA interface mode, etc.

If I reboot the sbRIO (Power off -> on) the RTTarget.LaunchAppAtBoot=False has been set to True again, without me manually editing ni-rt.ini.

 

What causes this behaviour?

 

Thank you.  Smiley Happy

 

 

0 Kudos
Message 1 of 3
(2,931 Views)
Solution
Accepted by topic author Freel

In your LabVIEW project, is the RTEXE build specification configured as 'Set as Startup'? I believe the LabVIEW project will attempt to 'deploy' the project settings each time a VI from the project is interactively run on the target.  So if that build spec retains that setting in the project, LabVIEW will overwrite your FALSE .ini token back to TRUE each time you run an interactive FPGA or RT VI in that project.  

 

I haven't been able to verify this behavior, but I suspect if you choose the option 'Unset as startup', that will stop LabVIEW from re-enabling your startup application after you manual set the .ini token to FALSE.  In general, this method for setting and unsetting the RTEXE as a startup application is probably more time efficient than manually editing the .ini file, and I've never had issues with the inconsistent behavior you are decribing when using this method.

 

Set as startup.png

 

Regards,

Spex
National Instruments

To the pessimist, the glass is half empty; to the optimist, the glass is half full; to the engineer, the glass is twice as big as it needs to be has a 2x safety factor...
Message 2 of 3
(2,919 Views)

I tested it and you are right. Thank you sir.  Smiley Happy

0 Kudos
Message 3 of 3
(2,908 Views)