LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Shared Variable on LM3S8962

Hi,

I am having problems in getting the LM3S8962 Evaluation board

to read/write Shared Variable. Reference to the following

Website resource:

 

http://digital.ni.com/public.nsf/allkb/6E50B28DDC61C0E68625767400805AA0?OpenDocument

 

When the download is running in the LM3S8962 Evaluation

board,Shared Variable communication is unsuccessful.

Does anyone know what's going on?

Thanks in advance

Mcusir

0 Kudos
Message 1 of 6
(4,620 Views)

Not sure if you still need help on this.  But here are few tricks to help your shared variable problem.

 

1.  Unless your LM3S8962 has access to central DHCP server, then you need to assign it a static IP address.

a) Under build specification>Communication options, uncheck Use DHCP and enter a static IP address and netmask.

b) Under shared variable setting, enter the IP address of your computer's ethernet card.  Also, it is advisable that you turn off wireless or anyother network card beside the one that you are using to talk to the LM3S8962.

 

2) Make sure you deploy the shared variable library.

 

3) Make sure Embedded Variable Connection Manager is running (LabView>Tools>Arm Module).

 

 

0 Kudos
Message 2 of 6
(4,577 Views)

Thank of Akonni’s help, I have to follow the steps to set up. The problem of shared variables  is still not resolved:

 

1. a) Under build specification>Communication options, uncheck Use DHCP and enter a static IP address and netmask.

 

 

1.PNG

 

b) Under shared variable setting, enter the IP address of your computer's ethernet card.

 

2.PNG 

 

2. Maked sure to deploy the shared variable library.

 

3. 

Maked sure Embedded Variable Connection Manager is running


3.PNG



0 Kudos
Message 3 of 6
(4,571 Views)

If you connect you board directly to your computer, you don't need to enter Gateway, Primary DNS and Secondary DNS.  Can you remove those and try again?

 

Also to check.

1) Ping your LM3S8962 from you computer.

2) If LM3S8962 can connect to your computer, you will also see its IP address shown up in the Embedded Variable Connection Manager as a client.

3) Check the .alias file for your project.  Make sure the IP address for My Computer has the same IP address as your embedded connection manager, ie 192.168.1.109.

0 Kudos
Message 4 of 6
(4,565 Views)

Thank Akonni, The problem of shared variables  is still not resolved :

 

IP地址设定.png

 

1) Ping your LM3S8962 from you computer.

命令符.png

 

2) IP address wasn't show up in the Embedded Variable Connection Manager as a client :

变量连接管理器.png

 

3) Check the .alias file :

 

 [My Computer]

My Computer = "192.168.1.109"

 


0 Kudos
Message 5 of 6
(4,557 Views)

I think at least you have narrowed down to that LM3s8962 wasn't showing up as a client in Embedded Variable Connection Manager.  Its a good place to call NI and ask the application engineer for help.

 

Also, here are few more things I would try:

1) Restart Embedded Variable Connection Manager, see if that helps.

2) Restart NI Variable Engine from Windows Services (Start>Run>Services.msc, Find National Instrument Variable Engine and restart that process)

3) Check in your distributed system manager, try to remove your existing SV library and then redeploy it.

 

0 Kudos
Message 6 of 6
(4,550 Views)