LabVIEW Embedded

Showing results for 
Search instead for 
Did you mean: 

Load FPGA bitfile on boot sbRIO


Hey Nimgaard,


It should work as expected with RIO 14.0.1. I have no issue here with my simple FPGA. You can send me a private message with your bitfile that I can deploy. The bitfile is compiled code so I can't see what you've done in your VI, so I don't have the source. Feel free to send me a private message for security purposes or you can upload it to with your choice of FTP clients. Only internal employees can access file uploaded to the incoming folder on the FTP server. 


I think the next best step would be to try repairing the NI RIO driver on your system and try again.


Mark should work with your further if you have any other questions. I'll try and stop by to follow up if I see an update.

Kyle Hartley
Software Engineer
0 Kudos
Message 11 of 13


I guess it is easier to just upload it here, being a bitfile and all.


I will try to repair the RIO installation as well and see if that changes anything.


/ Nimgaard

0 Kudos
Message 12 of 13

Hello! I'm using sbRIO 9607. The FPGA erased the VI when I boot up the sbRIO. When I tried to open RIO Device setup.... It doesn't show the device setting.

Please tell how can I run my VI after it boot?



0 Kudos
Message 13 of 13