LabVIEW Embedded

Showing results for 
Search instead for 
Did you mean: 

Load FPGA bitfile on boot sbRIO



I would like to load and start a FPGA bit file when my sbRIO-9626 boots. I found a setting for this in the RIO Device Setup, but if i try to set it to autoload on powerup or reboot the application hangs. I get a progress bar that just circles for however long i wait and i have to kill LabVIEW to abort it. The setting is not set.


I havent found much information about doing this on a sbRIO so i wonder if anyone have tried and succeded or if its a feature that simply doesnt work on sbRIO-9626.


I use LabVIEW 2012 sp1 if that helps.


To clarify, i want the FPGA bit file to load and start before my rtexe-file, or at the same time at least.




0 Kudos
Message 1 of 13

Hi Nimgaard,


Here is some information about loading a bit file to an FPGA target at startup:


If you are not using the FPGA module, here could be a useful link:


Here is some additional information about running an FPGA vi at startup:







Applications Engineer Intern
National Instruments UK and Ireland
0 Kudos
Message 2 of 13


Thanks for the answer.


The first link is pretty much the one i would like to do, but when i use the Rio Device Setup and press Apply Settings it just shows me a progress bar that keeps going for however long i wait to kill the process. Even after leaving it over a lunch for 90 minutes in total it didnt finish.


/ Nimgaard

0 Kudos
Message 3 of 13

Hey Nimgaard,


Sorry you are having trouble with the device setup utility. I've got a few things for you to try that should help narrow it down.


- Do you have another identical or similar unit you can try? That would help us figure out if it's bad hardware or if there is a software bug.


- Does the same bitfile work if you use it with the FPGA Open node? This will help rule out an issue with the lvbitx itself.





0 Kudos
Message 4 of 13


The bitfile is probably fine since i use it without any problems both standalone and together with my RT-application. Its just the loading on boot thats the issue.


I actually have plenty of sbRIOs of the same model (9626) available but im not entirely sure that ive tested the utility on more than one. I can give it a go on one or two others apart from the one i use for development and see if that helps when im at work tomorrow.


/ Nimgaard

0 Kudos
Message 5 of 13


I tried it on another unit with the same result. Applying the settings results in an endless progress bar.


/ Nimgaard

0 Kudos
Message 6 of 13

Hey Nimgaard,

Which version of the RIO driver are you using?

Kyle Hartley
Software Engineer
0 Kudos
Message 7 of 13

I just tried a simple bit file from LV 2012 with RIO 2012 and had no problem deploying a bitfile. Would you mind uploading you compiled bitfile and I can try deploying it to my system. 


I'd suspect its either a host software issue, Possibly a bad software update or a botched install. Did you change any software on your computer recently?



The other issue could be bad network connections from the host. We've seen similar issues if a host's network card is damaged (eq the network card on your pc) or if you are trying to deploy to a sbRIO that is very far away physically and trying to deploy across the network on internet.

You can also check any firewall settings. You can try disabling any firewalls to see if that is the problem.

Kyle Hartley
Software Engineer
0 Kudos
Message 8 of 13

I use RIO 14.0.1. Firewall is turned off on the network that i have the sbRIO on. Network status is hard to determine just from this, it works fine for all other operations. I can run both the FPGA and RT code interactively from my computer and while there is a network switch between the computer and sbRIO, its connected with cables roughly 1 meter long to both ends. The switch is also used exclusively for communicating with the sbRIO, no other units are connected to it.


I would have to check if its ok for me to upload the bitfile since i work with a customer application. I could email it to you if thats possible though.


I did update to LV2014 recently but it was reverted due to other issues. The install remains on my computer. The problem of setting the FPGA to run on boot happened before this as well. I have never seen it work on this computer. I noticed just now that i also get an error when trying to download the bitfile to flash from the RIO Device Setup. This have worked before.


Error -52003 occurred at an unidentified location

Possible reason(s):
An unexpected software error occurred.


Maybe this is related to the problem?


/ Nimgaard

0 Kudos
Message 9 of 13

You may need to repair RIO if you uninstalled LabVIEW after. It should be independent but sometimes things aren't independent. 


Let me try installing RIO 2014 and I'll let you know my results. 

Kyle Hartley
Software Engineer
0 Kudos
Message 10 of 13