LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW Embedded for ARM and LPC2478 for save data to SD-card

Hello!

 

I am use a LabVIEW Embedded for ARM for programming LPC2478 (Keil MCB2400) with SD-card .

I have a problem.

When I load a HEX code of program (on example : https://decibel.ni.com/content/docs/DOC-6254) in a LPC2478 board, I  receive error №21427 - PDAFileOpenNew (Open/Create/Replace File .vi). There is not a TXT file on SD.

 

How I can made TXT file on SD card?

 

Best Regards IgorZ. 

 

0 Kudos
Message 1 of 12
(6,523 Views)

have you tried the option "create" instead of "replace or create" ?

Wouter.
"LabVIEW for ARM guru and bug destroyer"
0 Kudos
Message 2 of 12
(6,513 Views)

Yes I tried all options

0 Kudos
Message 3 of 12
(6,147 Views)

Hi IgorZ, 

 

1) I think your path might be wrong. 

 

Try putting M:\ or C:\ in front of your "LabVIEW.txt" -even though you shouldn't need to it can't hurt to try. 

 

2) You also might double check that your are using a compatable SD card 

 

3) Another user had a similar problem, perhaps their solution will help you. 

 

Also, the explaination for this error is below: 

 

LabVIEW Embedded Module for ARM:  Failed to open file. This error can occur if the file path is invalid or multiple write operations attempt to open the same file.

 

Let me know how these steps go 

Jesse Dennis
Engineer
INTP
0 Kudos
Message 4 of 12
(6,130 Views)

Hello!

 

I have tried all variants which you to me have advised.

 

1. Not important what I specify the address "LABVIEW.TXT" or "C:\LABVIEW.TXT" the result - Open/Create/Replace File.vi gives out an error "№21427 - PDAFileOpenNew"

 

2. I use SD card 512MB FAT32 supporting “1-bit mode” and “SPI mode”

 

3. I have read a forum branch http://forums.ni.com/t5/LabVIEW-Embedded/MCB2300-SD-Card-Error/td-p/975321 . I has loaded MCB2400_SD_FILE.ZIP (http://www.keil.com/download/docs/369.asp). When I compile this project there is an error (see keil error.png). Can at me it is not adjusted uVision?

 

4. It is necessary to do additional options in file LPC2400.S which creates LabVIEW Embedded for ARM 2011 (example see keil setings.png)?

 

5. I work with LPC2478.

 

6. I used PC and created on SD card an empty file “LABVIEW.TXT”, inserted SD into device LPC2478 crack, but rewriting has not occurred.

The file remained empty.

 

IgorZ

 

Download All
0 Kudos
Message 5 of 12
(6,108 Views)

6. I used PC and created on SD card an empty file “LABVIEW.TXT”, inserted SD into device LPC2478 crack, but rewriting has not occurred.

The file remained empty.

 

- Have you tried it with a file that´s not empty?

 

- You can try to place it in a submap like M:\map\labview.txt

As I remember the get file info and get directory listing doesn't work in the root of a SD-card.

 

- Have you tried other SD-cards? (I had some huge problems with some SD-cards)

- You could debug the code in KEIL uVision by setting breakpoints in the SD-card handling and stepping trough it..

Wouter.
"LabVIEW for ARM guru and bug destroyer"
Message 6 of 12
(6,081 Views)

I have tried different SD cards and microSD with adapter, but the same result.

 

In the program has specified M:\map\labview.txt address On all cards I has created a folder “map”, but it has not helped. On all cards in folders “map” has created empty files Labview.txt, but files remained empty.

 

I am disturbed by that compilations of examples http://www.keil.com/download/docs/369.asp and http://www.keil.com/download/docs/380.asp are unsuccessful. uVision cannot find a file “File_Config.h” (keil error 2.png). Can be on mine PC there is not libraries or modules RL-ARM uVision?

 

If replace uVision 4.11 on uVision 4.53 I can to avoid the arisen problems?

Whether will work “LabVIEW Embedded for ARM2011”with uVision 4.53?

 

IgorZ 

Download All
0 Kudos
Message 7 of 12
(6,076 Views)

So if I am right, you have multiple examples that doesn't work.

the two keil examples (no labview for arm) and one labview application you have build.

 

you can stop trying to read/write from the transcend 4 GB (it's a SDHC and that's not supported by the  >> old << library's of FlashFS brought by NI)

 

the errors you get with the examples is about some files that it can't find.

Try the examples folder or boards folder in you installed Keil uVision.

I am sure that these examples will find it's files. 

 

when you're testing the labview build, try to debug it in keil uVision. (in LabVIEW menu bar >> tools >> show keil uvision ) 

do this after you have build your app, go to uvision, download and debug it. make breakpoints in some code of the SD-card File I/O and step trough it.

then you'll find where the error comes from.

If the examples from your keil folder work, compare the projects...

 

Wouter

Wouter.
"LabVIEW for ARM guru and bug destroyer"
0 Kudos
Message 8 of 12
(6,073 Views)

Good morning IgorZ, 

 

The  “File_Config.h” is a part of the RL_ARM library. In fact, it says on the example pages you found that this library is needed to compile. This library should have been installed when you installed LabVIEW for ARM and File_Config.h should be located somewhere like: C:\Program Files\National Instruments\LabVIEW 2011\Targets\Keil\Embedded\RealView\Drivers\ARM\Include

 

I don't think there is an installation bug here, as this is the only case we have documented of this library missing, but I do wonder if something went wrong with the installation. As a first step you can try repairing the module. 

 

I wouldn't try upgrading uVision just yet. The calls used from labview to uVision and other third party compilers are version specifc in some cases. If uVision changed something in their API from version to version the module wouldn't work. Additionally, there could be path and location problems. We should be able to get this to work with the version of uVision installed with the LabVIEW ARM module. 

 

 

Jesse Dennis
Engineer
INTP
0 Kudos
Message 9 of 12
(6,066 Views)

Hello!

 

 

Excuse me for a big break, there were urgent matters.

 

I managed to create the file on SD card (read, write, rewrite) only on lpc2378, the same program didn't work at lpc2368.

 

Whether there is a basic difference of compilation of programs for lpc2378 and for lpc2368?

Best regards, IgorZ

 

0 Kudos
Message 10 of 12
(5,919 Views)