LabVIEW Embedded

cancel
Showing results for 
Search instead for 
Did you mean: 

CPU to 100% ISR to 72% LabVIEW RT Phar Lap with 1553 communication

Highlighted

Development software: LabVIEW RT 2014
Hardware: PXI RT , Excalibur M4k1553px on Exc-4000cPCI carrier board, PXI NI 6683, A separate monitor connected to PXIRT's DP port to check CPU status and program status on PXI real time. 
Mode: Simulating Remote Terminal communication on 1553 , Bus controller external and all A&B cables are connected with Bus coupler with proper 78 Ohm terminators. No mode code or error injections
Issue: Simulation of 1553 works but real time PXI systems locks up, CPU#0 that goes to 100% and ISR (Interrupt service request) to 72% when (ONLY) 1553 communication starts simulating (or by calling ExcM4kP Run RT function). 

 

http://www.mil-1553.com/Excalibur/Templates/showpage.asp?DBID=1&LNGID=1&TMID=108&FID=1535&IID=3221

0 Kudos
Message 1 of 5
(2,941 Views)

Hi Shahab_S,

 

Which driver are you using for 1553? How are you implementing it in LabVIEW? What exactly does your code do, and does your PXI controller rail when doing a simple 1553 communication task?

 

Nick

Applications Engineer

0 Kudos
Message 2 of 5
(2,897 Views)
Highlighted

Location of driver, you need to have profile to get the LaBVIEW RT driver and then the shipping example was ExcM4kP App RT Get Messages.vi 

 

http://www.mil-1553.com/4000-family

m4k1553pcipx-viRT-win(2.3 Mb) Labview RT drivers

Shipping example in the driver tree: ExcM4kP App RT Get Messages.vi 

Thanks

 

0 Kudos
Message 3 of 5
(2,889 Views)
Highlighted

Hi Shahab_S,

 

We need more information about what's actually going on. A few questions:

 

  • What are your specific questions about this application?
  • Are you receiving error messages, or is there an error log on the controller (found by right-clicking the target -> "View Error Log")?
  • Does the controller ever free up, or do you have to restart it to regain functionality?
  • Have you narrowed down the lock-up to that one particular ExcM4kP Run RT function?
  • Does this happen on other PXI controllers?
  • Has this ever worked before? If so, what changed?

 

Nick

Applications Engineer

0 Kudos
Message 4 of 5
(2,883 Views)
Highlighted
  • What are your specific questions about this application? 

Issue: Simulation of 1553 works but real time PXI systems locks up, CPU#0 that goes to 100% and ISR (Interrupt service request) to 72% when (ONLY) 1553 communication starts simulating (or by calling ExcM4kP Run RT function). 

 

  • Are you receiving error messages, or is there an error log on the controller (found by right-clicking the target -> "View Error Log")?

No error on target related to this issue. 

  • Does the controller ever free up, or do you have to restart it to regain functionality?

Controller never free up and yes killing the power of PXI RT is the only way to get back and try again.

 

  • Have you narrowed down the lock-up to that one particular ExcM4kP Run RT function?

When ExcM4kP Run RT is called which is start of 1553 communication this lock up occurs. 

 

  • Does this happen on other PXI controllers?

It happens to all other 4 controllers, and Excalibur company also able to replicate the same issue with their shipping LabVIEW example which I posted as link earlier on thread    

  • Has this ever worked before? If so, what changed?

This has never served us as robust system, we want to make the system that NEVER shows 100% CPU.  

{BTW over all program is designed to work under 3% CPU load, No crazy loops without wait function. And also tried timed loop to shift the entire program to CPU 1, still CPU 0 gets upset and zips to 100%  and did not help at all} 

 

0 Kudos
Message 5 of 5
(2,860 Views)