LabVIEW Development Best Practices Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQ 9234 keep disconnected from PC

Highlighted

Hi all,

I'm using DAQ 9234 to measure sound (microphone) and vibration (velocity) wave for developing an automation tester in a production line I am working on.

But I'm having a problem which the DAQ 9234 (with DAQ 9171 as a USB chassis) keep disconnected from PC, and I need to re-plug the USB to get it re-connect.

I heard that this DAQ have been stopped.

Is there anyone in the group seen such connection problems?

Thanks.

0 Kudos
Message 1 of 10
(4,370 Views)

You may get a better response on a DAQ specific group. Try posting your question here:

http://forums.ni.com/t5/Multifunction-DAQ/bd-p/250

Message 2 of 10
(1,709 Views)

Just a quick thought, and may not be related at all.

I have had problems in the past with Win7 shutting down USB devices.USB Power Mgmnt.png

Good luck,

James

PS. I agree with David, this isn't the best forum for this question.

Systems Engineering
LabVIEW 5.0 - 2018
0 Kudos
Message 3 of 10
(1,709 Views)

kipizoki,

I agree you may have better luck with the technical content of your post in another forum, but since you posed the question...

Signal.X specializes in noise and vibration applications for production testing, and generally speaking we stick to PCI and PXI platforms for these systems because of the reliability and uptime expectation that they generally have.  If you have any questions about how we do this and why, feel free to contact me.and we can chat further.

Thanks,

Rob

0 Kudos
Message 4 of 10
(1,709 Views)

Hi Rob,

Thanks for the reply, actually, the problem I faced is the DAQmx task runs successfully for some time, but then returns Error -50808.

I already go thorugh all of the forum links below and follow their suggestion but I'm still can't get it fixed.

1. https://www.google.com.my/search?q=Error+50808&ie=utf-8&oe=utf-8&rls=org.mozilla:en-USSmiley Surprisedfficial&client...

2. http://forums.ni.com/t5/LabVIEW/LabVIEW-cDAQ-Error-50808/td-p/2839770

3. https://decibel.ni.com/content/docs/DOC-9846

0 Kudos
Message 5 of 10
(1,709 Views)

Is it on a USB hub? If so, plug it directly to the PC.

0 Kudos
Message 6 of 10
(1,709 Views)

yes, it is on powered usb hub.

is there any difference?

0 Kudos
Message 7 of 10
(1,709 Views)

What is the behavior when plugged directly to the of with no hub? Does it still have the problem?

0 Kudos
Message 8 of 10
(1,709 Views)

yes.it does..i can only do 1 time read,and it got disconnected for the 2nd

time read..

0 Kudos
Message 9 of 10
(1,709 Views)

Tell us more about your system/set up. OS, hardware etc.

I've had similar issues in the past where it turned out to be a dodgy USB3 driver. Fixed by either uninstalling the USB3 driver or updating the BIOS.

Troy - CLD "If a hammer is the only tool you have, everything starts to look like a nail." ~ Maslow/Kaplan - Law of the instrument
0 Kudos
Message 10 of 10
(1,709 Views)