LabVIEW Cloud Toolkits

Error 7 on CRIO 9066

I'm new to using the cloud toolkit for AWS. I have basic code that uses the upload file to bucket vi. I have no issues when running on my computer but get the attached error 7 when running code from my CRIO 9066. The same error occurs when using any vi that interacts with AWS.  

 

Any ideas?

0 Kudos
Message 1 of 7
(2,597 Views)
6 REPLIES 6

Re: Error 7 on CRIO 9066

I think this is most likely an issue with creating the paths for Linux RT.  Take a look at the Working with File Paths on Real-Time Targets tutorial and see if you are following the path structure for Linux RT.

 

What path are you passing to the Upload File to Bucket node?

0 Kudos
Message 2 of 7
(2,589 Views)

Re: Error 7 on CRIO 9066

I use the path /C/DATA/Test.csv to reach a DATA folder on the cRIO. I use the same path to create and update the csv file and do not have any issue updating the file on the cRIO. The issue only arises when attempting to communicate with AWS.

0 Kudos
Message 3 of 7
(2,587 Views)

Re: Error 7 on CRIO 9066

I think it isn't finding the HTTP library.  Run one of the HTTP examples and verify that you get the same error.  If so, run vi.lib\httpClient\Get Lib.vi and see what it returns.  It should point towards the HTTP library.

 

Let me know what you find.

 

Cheers,

Brandon

0 Kudos
Message 4 of 7
(2,576 Views)

Re: Error 7 on CRIO 9066

Can you clarify what you mean by HTTP example? Withing the labview examples, the web services - weather monitor RT example works between the CRIO and my computer without any issue. 

 

The Get Lib.vi is password protected and I can't run it stand alone because it is in private scope so I do not see an obvious way to run it from the CRIO. 

0 Kudos
Message 5 of 7
(2,555 Views)

Re: Error 7 on CRIO 9066

As a temporary workaround, I am using a dedicated laptop connected the the cRIO so that the data is moved from the cRIO to my laptop and then from my laptop to AWS using a cellular modem. 

 

No luck connecting the cRIO directly to cellular modem to communicate with AWS.

0 Kudos
Message 6 of 7
(2,378 Views)
Highlighted

Re: Error 7 on CRIO 9066

I had a similar problem on a 9039. Ended up the solution in my case was to install HTTP Client with SSL Support on the CRIO using Add/Remove software in NI-Max. See this for details.

0 Kudos
Message 7 of 7
(46 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.