LabVIEW Cloud Toolkits

cancel
Showing results for 
Search instead for 
Did you mean: 

AWS example on myRIO error

Solved!
Go to solution

NI_AWS_Core.lvlib:HTTP Request.lvclass:Create Error Cluster from Response Body.vi<ERR>
Signature expired: 20171227T080421Z is now earlier than 20171228T021459Z (20171228T022959Z - 15 min.)

Check your system's date, time, and timezone settings. Adjust for Daylight Saving Time if necessary.


<b>Complete call chain:</b>
     NI_AWS_Core.lvlib:HTTP Request.lvclass:Create Error Cluster from Response Body.vi
     NI_AWS_Core.lvlib:HTTP Request.lvclass:Check Error and Get Call Result.vi
     NI_AWS_Core.lvlib:HTTP Request.lvclass:Send API Request v4.vi
     NI_AWS_Core.lvlib:HTTP Request.lvclass:Make HTTP Request v4.vi:480001
     NI_AWS_Core.lvlib:HTTP Request.lvclass:Low-Level HTTP Request AWS v4.vi:4270001
     NI_AWS_SQS.lvlib:Queue.lvclass:List Queues.vi
     List SQS Queues in Region.vi

 

I got that error when i run aws list queue example in myRIO.

 

Anyone know what to do?

Kudos and Marked as Solution == Thanks
0 Kudos
Message 1 of 6
(3,057 Views)

I try to change the time too, but nothing works.

Then i try to instal new software in myRIO and it works, but the next day it is not working again. Then i just restart myRIO, suddenly it works.

 

Anyone know what is this error caused?

Is it bug?

Kudos and Marked as Solution == Thanks
0 Kudos
Message 2 of 6
(3,054 Views)

It is error again after i shutdown myRIO for a couple of hour

Kudos and Marked as Solution == Thanks
0 Kudos
Message 3 of 6
(3,042 Views)
Solution
Accepted by topic author Pelabu

It appears that we may not restart myRIO because the time will reset

Kudos and Marked as Solution == Thanks
0 Kudos
Message 4 of 6
(3,027 Views)

I get the following error while trying the AWS SQS example on myRIO. It works OK on the computer but I get the following error during deployment:

 

Deploying NI_AWS_Core.lvlib:HTTP Request.lvclass:Make HTTP Request v4.viNI_AWS_Core.lvlib:HTTP Request.lvclass:Make HTTP Request v4.vi loaded with errors on the target and was closed.
Deployment completed with errors

 

The time setting is OK, the HTTP client is installed and the admin password is not empty.

0 Kudos
Message 5 of 6
(1,611 Views)

hi there!

I'm working on remote monitoring of real time temperature monitoring project using labview. for the IOT application I have to upload data in the form of excel sheet which is generated by labview, and at the user end I have to monitor it on mobile application, so can anyone suggest me the IOT platform for this project which would be compatible with Labview

 

0 Kudos
Message 6 of 6
(1,196 Views)