LabVIEW APIs Discussions

Showing results for 
Search instead for 
Did you mean: 

scripting in EXE


someone can confirm me that "New VI Object" don't work in EXE application?

i'm looking for some doc, advice or warning that confirm that but i still didn't found nothing.

This is a big big problem for me, i develop for 3 weeks and only now i discover this limitation (if it is)

When i run my exe app it hang forever inside New VI Object whitout error.

I know that maybe is related to the fact that the LV Run-Time can't perform some operations related to a VI in particular operation that requires a VI recompilation.

Other question: is this a Technical or a "commercial" issue?


0 Kudos
Message 1 of 13


I confirm that scripting doesn't work in EXEs, I think this has always been very clear in the scripting licence.

It is also documented in LabVIEW's context help, I think all the scripting methods have a Note that says "Available in the LabVIEW Run-Time Engine: No"

Hope this helps

We have two ears and one mouth so that we can listen twice as much as we speak.


Antoine Chalons

0 Kudos
Message 2 of 13

As said scripting is an IDE feature only. And while there is definitly some commercial reason for that, the real fact is a technical. The RTE is made to run LabVIEW code, not to create, modify, recompile and whatever it. As such it does not contain most of the LabVIEW routines that deal with these edit operations at all. This includes anything that has to do with compilation of VIs but also many operations such as saving VI code, etc.

Rolf Kalbermatter

CIT Engineering Netherlands

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 3 of 13

true most of scripting function has this note, but New VI Object no.

0 Kudos
Message 4 of 13

from my point of view the real reason is commercial i'll accept to pay for a "advanced RTE" able to execute scripting functions.

Your example of saving VI is also a good point, this function isn't scripting and, as far as i know, is available since LV 4.0 (maybe before?)  but don't work in EXE, can be this a techinical issue or "simply" a commercial one?

Just to clarify i love LabVIEW and for this reason is very sad when you have IMO the best programming language in your hand and you can't do simple stuff like save a VI from your exe.

0 Kudos
Message 5 of 13


  I asked around about your question, and have some information that might help you out.

  We're usually hurting to keep the size of the runtime engine small.  In looking for things to take out to make it smaller, the compiler was an attractive option to trim.  We've had some features that really need a compiler in the runtime engine though, so we have a version of the runtime engine that includes it.

  If you go to your LabVIEW install media, you'll see an option somewhere in the menu hierarchy for 'Support for TestStand'.  This installs the "full-featured" runtime engine to your system, which should then show up as an option in the application builder when building your EXE.

  I'm not positive that your code will start working in the full-featured runtime, but I suspect that it will.

  The full-featured runtime is a workaround for a problem that we wish we didn't have, so I can't promise that it will keep existing in future versions of LabVIEW.  Also, the full-featured runtime doesn't get a lot of test coverage beyond what we need to do to make sure our internal use cases work correctly, so swim at your own risk.

  -Trevor Christman

0 Kudos
Message 6 of 13

Thanks for your precious reply Trevor.

i'm trying what you suggest but i'm not sure to make the correct thinghs.

I ran the installa of NI produts from my DVD NI dev suite 2009 Q2 but i don't see nothing related to support fo teststand... so i start looking at the file inside the DVDs, i testand folder i found TestStand/Products/LabVIEW_FF_Runtime_Engine_86/lvffrte/lv86ffruntime.msi are FF stand for full feature? i tried to install it but seems to be related to DSC infact my test app still don't work in exe mode... maybe i lost some part of your description could you please help me again?


0 Kudos
Message 7 of 13

From the platform DVD installers, do a custom installation of LabVIEW.  When you're presented with the LabVIEW components, it's in Additional Features > Remote Execution Support for NI TestStand.  The suggestion did not work for me.  I had to enable enhanced DSC support and debugging, then I could use scripting methods in a LabVIEW exe.

0 Kudos
Message 8 of 13

You must install "labview ff runtime" and "labview runtime".

0 Kudos
Message 9 of 13

I am having the same issue.

It sounds like I need to install either "LabVIEW ff runtime" or "Remote Execution Support for NI TestStand" on my development machine.

Can someone confirm this?


0 Kudos
Message 10 of 13