LabVIEW APIs Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

.NET Assembly Changed Expected Version=1.4.3372.25547 but Found Version=2.1.0.0

Hello,

I am trying to communicate to an Arcoptix spectrometer through example code that was provided with it. I am using LabVIEW 2011 due to some older equipment being interfaced with this version and I would like to use this version as well for the spectrometer. When running the example VI I get a warning saying .NET assembly changed and then the details say expected assembly "ARCsoft.ARCspectro Md, Version1.4.3372.25547, Culture=neutral, PublicKeyToken=null", but found "ARCsoft.ARCspectroMd, Version=2.1.0.0, Culture=neutral, PublicKeyToken=null."

I am out of ideas on how to solve this issue. I have tried placing a configuration file in the directory to try and force LabVIEW to use the correct .NET assembly version but had no luck. I also downloaded LabVIEW 2017 and done the same steps and got the same error message. Does anyone know of a way to fix this?

 

Thanks

Message 1 of 3
(956 Views)
Highlighted

Same problem here, I'll let you know if I figure it out.

0 Kudos
Message 2 of 3
(505 Views)

Figured it out. Since I'm using an older (different) version of LabVIEW than what the dll's/libraries/VI's were compiled for, I just had to recompile them.

 

So in my case, the libraries with the problem were in a folder called "ULx": Since I'm using an older version of Labview (2011), I had to re-compile the vi's/libraries. In LabVIEW 2011, under Tools -> Advanced -> Mass Compile, I chose the Ulx folder in National Instruments -> Labview 2011 -> vi.lib --> ULx and compiled. Then restarted my computer and it worked. Maybe this will help you or someone else who comes across this.

0 Kudos
Message 3 of 3
(500 Views)