LINX

cancel
Showing results for 
Search instead for 
Did you mean: 

Reboot LabVIEW chroot on Raspberry Pi

Solved!
Go to solution

I am trying to reboot only the LabVIEW chroot on the Raspberry Pi like what is done when you deploy a new program to the Pi.  Based on my understanding LabVIEW is running in its own chroot and I have tried to end or restart the session based on the schroot options.  I am not sure if I need to stop the process running in the LabVIEW chroot or if I need to mount something again after running this command.  Here is what I am seeing when trying to run these commands:

 

schroot recover sessionschroot recover session schroot end sessionschroot end session

 

After running the recover-session or end-session commands the lv chroot is no longer found.  I can confirm that the LabVIEW program stopped running after running these commands.

 

Note that the shutdown command is not available in the LabVIEW chroot.

 

Is there a way to view the commands that the LabVIEW environment on the PC is sending to the Raspberry Pi when the program is downloaded so that I can see how to properly reboot the LabVIEW environment on the Pi?

 

Thank you in advance for any assistance. 

0 Kudos
Message 1 of 4
(393 Views)

Note that the shutdown command is not available in the LabVIEW chroot.

0 Kudos
Message 2 of 4
(392 Views)
Solution
Accepted by topic author DavidWilt

The best way to do this is using systemd, not directly through schroot.

 

Use this command to check the chroot status:

systemctl status labview.service

 

Use this command to stop the chroot (and LabVIEW):

sudo systemctl stop labview.service

 

You can also restart or stop the chroot by substituting "restart" or "stop" in the above command.

Message 3 of 4
(361 Views)

Thank you very much.  That accomplishes what I was looking for.  By using:

sudo systemctl restart labview.service

I am able to get the LabVIEW environment to reboot without effecting the Pi OS environment.

 

Now I got to see if I can SSH from my NXG web interface to reboot the LabVIEW environment as required.

0 Kudos
Message 4 of 4
(349 Views)