LINX

cancel
Showing results for 
Search instead for 
Did you mean: 

LabView 2020

I tried a brand new Arduino. Loaded the linx firmware, watched the blinking led's. It still did not work. Went back to Labview 2019 and it connected with no issues and communicated.

0 Kudos
Message 11 of 50
(492 Views)

Interesting. I assume you are using the windows 10 version of labview community 2020? And you are using a genuine arduino mega 2560, not from a 3rd party maker?

 

I will see if I can reproduce with a genuine arduino mega 2560 that I have at home. I just tried with an arduino uno and had no problem running example blink.

0 Kudos
Message 12 of 50
(483 Views)

K, I was able to reproduce your error code 5003 like in your screenshot on page 1 of this forum subject.  I used a genuine arduino mega 2560 R3 loaded with the LINX firmware wizard using labview 2020 version 20.0 32 bit community for windows 10, digilent LINX version x.x.x (unknown version, since JKI VI Package Manager says I have not installed the latest, which is 3.0.1.192), NI LabVIEW LINX Toolkit version 1.0.0.9 is apparently also not released.  I will install 3.0.1.192 and see if this error goes away.

 

EDIT: apparently I have NI LabVIEW LINX Toolkit version 1.0.0.9 since it tells me to NOT download this version, since it is the version that comes standard with labview community 2020.

0 Kudos
Message 13 of 50
(478 Views)

Thank you, glad you are able to replicate it.

 

I an running  Professional LabView 2020 not the Community version.

0 Kudos
Message 14 of 50
(467 Views)

Hmm not sure how to document this to get this fixed. Could you try to file a problem ticket? Since you have a professional license they may file it.

0 Kudos
Message 15 of 50
(461 Views)

I raised a Ticket with NI and they basically said it's not their problem.

"The LINX Toolkit is a third party toolkit that is not maintained nor supported by NI. Having a look at the support options available for the LabVIEW LINX Toolkit, the creators of this toolkit advice is to use the MakerHub forum to post questions and look for support. Hence my first recommendation for yourself is to create a forum post on the MakerHub Forum. An additional option is to also post your question on the JKI VIPM forums.

0 Kudos
Message 16 of 50
(458 Views)

They did say try the Commercial version but I didn't want yet another version downloaded but it sounds like that is what you are using and it still doesn't work.

0 Kudos
Message 17 of 50
(456 Views)

@Colinvellacott wrote:

They did say try the Commercial version but I didn't want yet another version downloaded but it sounds like that is what you are using and it still doesn't work.


You mean community?

 

yeah the maker forum

is dormant. The mods no longer approve my posts. I read the mod has not been active in months. This needs to be fixed. NI is pointing us to labviewmakerhub.com forum but the website is deprecated.

0 Kudos
Message 18 of 50
(452 Views)

sorry yes community 

0 Kudos
Message 19 of 50
(447 Views)

Someone at NI clearly isn't fully aware of the current state of Linx. The Makerhub website is indeed inactive and users are actively refered to this forum group instead. When NI created the Community Edition, they didn't quite take over Linx, but took direct responsibility for it. The current version of the Linx Toolkit as shipped for LabVIEW 2020 does NOT seem to be the one on the Makerhub github account and I haven't found a newer repository on the NI github portal. So someone at NI obviously made some changes to the Linx Toolkit for the latest version but that doesn't seem to be all on github.

 

That doesn't sound like a fully 3rd-party provided library at all to me. Obviously they do not quite want to take full ownership of it and in its current state it is pretty hard to support in a consistent manner. There are many promisses made about supporting various embedded controllers in one way or the other, but trying to support such a vast array of hardware is practically unsupportable beyond the current model of "Here is what you get, if it works it's nice, if not you have to get your hands yourself dirty and start figuring out why!"

Also the current underlaying implementation lacks various things such as a consistent error reporting that would help pinpoint possible error causes more clearly. Also it is far not modular enough in order to easily support all the different hardware modules it is supposed to run on. Another issue is the LabVIEW project integration, which suffers from the fact that some lower level part of it is NI closed source and you only get the documentation about how that has to be done, when signing some NDA.

 

So saying it's third party and we can not support it is a very easy but in fact false statement. On the other hand, to support a Toolkit like this would require some serious resource commitment, so I can see why NI does not want to do that in its current state. First there would need to be a more clear architecture and second to fix many of the trouble found, you really need to have the according hardware available and while those boards all don't cost an arm and a leg, setting them up for a debug session is a serious undertaking, and needs to be done almost everytime again.

 

The main problem is that this community is pretty small and therefore there are only a few who have the knowledge, expertise, time and motivation to really work on it. And for NI there is no direct commercial gain in it that would allow them to assign a few engineers more or less fulltime on it.

Rolf Kalbermatter
Averna BV
Message 20 of 50
(435 Views)