LINX

cancel
Showing results for 
Search instead for 
Did you mean: 

Installation fails: LabView 2020 Professional with Raspberry Pi Model 3 B+

Hi there,

 

i am constantly failing to install Linx Software on Raspberry Pi Modell 3 B+

I use LabView 2020 Professional and Linx Toolkit for LV2020 (Version 1.0.0.9)

 

I can connect to the target, but the Software Upgrade fails.

Its weired though, that the Linx Software recognises the Raspberry PI as Model 2... this is wrong. I have a Model 3 B+

 

Has anybody an idea whats going wrong?

 

 

Connecting to target...
Successfully connected to target.
Successfully connected to the target.
Target configuration updated.
OS Version: 10.6
CPU: BCM2835
Systemd Version: 
Has Internet Access: True
Device Type: Raspberry Pi 2 B

blacklist spi-bcm2708is not present.dtparam=spi=on already exists.i2c-dev already exists.i2c-bcm2708  already exists.blacklist i2c-bcm2708is not present.dtparam=i2c1=on already exists.dtparam=i2c_arm=on already exists.
Adding MakerHub feed...
MakerHub Feed Already Exists
Updating package index.  This may take over 30 seconds depending on your internet speed...
OK:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
OK:2 http://archive.raspberrypi.org/debian buster InRelease
Ign:3 http://feeds.labviewmakerhub.com/debian binary/ InRelease
Ign:4 http://feeds.labviewmakerhub.com/debian binary/ Release
Ign:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
Ign:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
Ign:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
OK:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-de
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE
Ign:9 http://feeds.labviewmakerhub.com/debian binary/ Translation-de_DE.UTF-8
Paketlisten werden gelesen...
Installing LabVIEW...
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
lvrt20-schroot ist schon die neueste Version (20.0.0-4).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 15 nicht aktualisiert.
Rebooting Target...
Successfully connected to target.
Checking target status...

Installation failed.  If this is the first time the installation has failed try again.  If this error persists search, then post on the LabVIEW MakerHub forumsat labviewmakerhub.com/forums/linx.
Target configuration updated.
OS Version: 10.6
CPU: BCM2835
Systemd Version: 
Has Internet Access: True
Device Type: Raspberry Pi 2 B

 

 

0 Kudos
Message 1 of 8
(600 Views)

Hi derandyk!

Same problem with rPI 3b and rPI4b. But although it results in the error and although the installer recognizes  rPI3b and 4b as 2b, it works with all devices i tested.

But I'm still interested to know what causes the error and what effects it shows.

Franz

0 Kudos
Message 2 of 8
(581 Views)

Hi Aui,

 

my problem is, that it doesnt work and I am not so familiar with the Linux Shell.

When I check the installation status of the lvrt-schroot package, i got the following:

 

I am wondering what i means: "Status: install ok not-installed"

 

pi@raspberrypi:~ $ dpkg -s lvrt-schroot
Package: lvrt-schroot
Status: install ok not-installed
Priority: optional
Section: base
Architecture: armhf

 

Somebody here, who can give an interpretation of this?

 

Thank you in advance!

 

Andy

0 Kudos
Message 3 of 8
(571 Views)

Hi there,

 

to make my confusion complete, I checked the status of the process:

Oh wonder, the process is running🤔

 

pi@raspberrypi:~ $ sudo systemctl -l status labview
● labview.service - LabVIEW 2020 chroot run-time daemon
   Loaded: loaded (/etc/systemd/system/labview.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2020-10-06 14:35:19 CEST; 2h 39min ago
  Process: 4447 ExecStartPre=/usr/sbin/schroot-lv-start.sh (code=exited, status=0/SUCCESS)
  Process: 4598 ExecStart=/usr/bin/schroot --run-session -c lv -- /etc/init.d/nilvrt start (code=exited, status=0/SUCCESS)
 Main PID: 4605 (MainAppThread)
    Tasks: 0 (limit: 2065)
   CGroup: /system.slice/labview.service
           ‣ 4605 ./lvrt

Okt 06 14:35:18 raspberrypi systemd[1]: Starting LabVIEW 2020 chroot run-time daemon...
Okt 06 14:35:19 raspberrypi schroot-lv-start.sh[4447]: lv
Okt 06 14:35:19 raspberrypi schroot[4598]: pam_unix(schroot:session): session opened for user root by (uid=0)
Okt 06 14:35:19 raspberrypi schroot[4598]: Starting LabVIEW
Okt 06 14:35:19 raspberrypi schroot[4598]: pam_unix(schroot:session): session closed for user root
Okt 06 14:35:19 raspberrypi systemd[1]: Started LabVIEW 2020 chroot run-time daemon.
pi@raspberrypi:~ $ date
Di 6. Okt 17:15:03 CEST 2020

 

How can it be, that the status says "not installed" and the process is running but the whole thing doesnt work...?

 

Strange...

 

Thank for suggestions, anyway.

 

Andy

0 Kudos
Message 4 of 8
(563 Views)

Has nobody an idea?

I cant believe, that I am the only one with the same issue...

 

What's your experience with LV2020 Professional and Raspberry PI Modell 3 B+?

Message 5 of 8
(514 Views)

Is the Labview 2020 the 32 bit or 64 bit Version?

Up to now only 32 bit seems to be supported. I would be happy if someone tells me that 64 bit is possible.

 

0 Kudos
Message 6 of 8
(466 Views)

Hello hello,

 

no solution unfortunately.


I just wanted to add hopefully without hijacking this thread: I have pretty much the same installation problem but with the Raspi 3 Model B without the "+"  that Linx also recognizes as Raspi 2?

The installation always fails. I might add that I always get the prompt of an unexpanded partition again and again with a the partition size of supposedly 6 GB of 9 GB which is then supposedly fixed. This is strange because I have a 16GB SD-Card an ensured an expanded partition. If I retry the installation the dialogue appears again... 

I use the Labview 2020 Community Edition which is the 32bit version. 


Maybe I could try the manual installation of the Labview runtimes on the Raspi? What I found on the web did not work so far...

Any hints appreciated!

Thanks in advance

 

 

 

 

 



Connecting to target...
Successfully connected to target.
Successfully connected to the target.
Target configuration updated.
OS Version: 10.6
CPU: BCM2835
Systemd Version: 
Has Internet Access: True
Device Type: Raspberry Pi 2 B

Expanding file system.
Rebooting Target...
Unable to connect to the target. Please make sure the specified Hostname/IP, Username and Password are correct and try again. If this problem persists please search then create a thread on the Makerhub forums at labviewmakerhub.com/forums/linx.
Unable to connect to the target. Please make sure the specified Hostname/IP, Username and Password are correct and try again. If this problem persists please search then create a thread on the Makerhub forums at labviewmakerhub.com/forums/linx.
Unable to connect to the target. Please make sure the specified Hostname/IP, Username and Password are correct and try again. If this problem persists please search then create a thread on the Makerhub forums at labviewmakerhub.com/forums/linx.
Successfully connected to target.
Warnings dialog continued.
blacklist spi-bcm2708is not present.dtparam=spi=on already exists.i2c-dev already exists.i2c-bcm2708 already exists.blacklist i2c-bcm2708is not present.dtparam=i2c1=on already exists.dtparam=i2c_arm=on already exists.
Adding MakerHub feed...
MakerHub Feed Already Exists
Updating package index. This may take over 30 seconds depending on your internet speed...

Installing LabVIEW...

Rebooting Target...
Unable to connect to the target. Please make sure the specified Hostname/IP, Username and Password are correct and try again. If this problem persists please search then create a thread on the Makerhub forums at labviewmakerhub.com/forums/linx.
Unable to connect to the target. Please make sure the specified Hostname/IP, Username and Password are correct and try again. If this problem persists please search then create a thread on the Makerhub forums at labviewmakerhub.com/forums/linx.
Successfully connected to target.
Checking target status...

Installation failed. If this is the first time the installation has failed try again. If this error persists search, then post on the LabVIEW MakerHub forumsat labviewmakerhub.com/forums/linx.
Target configuration updated.
OS Version: 10.6
CPU: BCM2835
Systemd Version: 
Has Internet Access: True
Device Type: Raspberry Pi 2 B

 

And the process also seems to be running:

 

pi@raspberrypi:~ $ sudo systemctl -l status labview
● labview.service - LabVIEW 2020 chroot run-time daemon
   Loaded: loaded (/etc/systemd/system/labview.service; enabled; vendor preset: 
   Active: active (running) since Fri 2020-10-16 22:55:59 CEST; 13min ago
  Process: 1354 ExecStartPre=/usr/sbin/schroot-lv-start.sh (code=exited, status=
  Process: 1505 ExecStart=/usr/bin/schroot --run-session -c lv -- /etc/init.d/ni
 Main PID: 1512 (MainAppThread)
    Tasks: 0 (limit: 2065)
   CGroup: /system.slice/labview.service
           ‣ 1512 ./lvrt

Okt 16 22:55:58 raspberrypi systemd[1]: Starting LabVIEW 2020 chroot run-time da
Okt 16 22:55:59 raspberrypi schroot-lv-start.sh[1354]: lv
Okt 16 22:55:59 raspberrypi schroot[1505]: pam_unix(schroot:session): session op
Okt 16 22:55:59 raspberrypi schroot[1505]: Starting LabVIEW
Okt 16 22:55:59 raspberrypi schroot[1505]: pam_unix(schroot:session): session cl
Okt 16 22:55:59 raspberrypi systemd[1]: Started LabVIEW 2020 chroot run-time dae

 

 

0 Kudos
Message 7 of 8
(439 Views)

Dear all,

 

LINX for raspberry pi ONLY works on 32-bit architecture.

 

I´m using Labview2014 (Professional Edition) and recently Labview2020 (Community Edition) on both works fine.

 

Some tips.

 

The raspbian version that works is Strech, new distros not work at all.

 

If you have a prevously version of Labview installed on Raspberry pi and try to install a new one, it not work, normally a message warning you that "partition must be expanded", but at the end it not work at all. You need to install the new version that you want from a clean image of raspbian (strech distro).

 

For installation is better to do it with a wired connection to raspberry pi, instead of wireless.

 

When you install Labview throught LINX Target Configuration Tool, at the end a confusion message appearing "Not installed", but if you create a project in Labview for RT target it will work. For this follow the instructions on Makerhub webpage.

 

Best regards.

 

0 Kudos
Message 8 of 8
(187 Views)