Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

pci-8431/2

I am using PCI-8431/2 with 3.5.1 driver for 2 wire/auto RS-485. The operating system is windows 2000.

I not able to communicate, even loop back test give me time out error.

But ok with windows xp with 3.6  driver.

 

Any ideas or help are much appreciated.

 

Regards

Jey

0 Kudos
Message 1 of 5
(1,269 Views)

Hello Jey,

 

Thanks for bringing this issue to the forums. I'd like you to answer a few questions to pin-point the problem.

1. Can you use the onboard serial port on your computer? (not the PCI 8431/2)

2. Can you further describe your setup? Any external hardware? Are you using LV?

3. What version of Measurement and Automation Explorer do you have? What version of LV?

4. Is there a praticular reason you are using a Windows 2000 OS? 

 

Thank you,

Vimal Fernandez


ELP Engineer

Applications Engineering

Applications Engineer
National Instruments
0 Kudos
Message 2 of 5
(1,251 Views)

Thanks for get back to me. The OLD Replacement PC. We are planning to get new PC with XP operating system.

 

For the time beinng, I found a way to communicate with unit.

 First select 4 wire communication to establish the communiction, the switch back to 2 wire Auto to perform the proper communication and beleive XP and latest driver will eliminate this issue.

 

regards

Jey

0 Kudos
Message 3 of 5
(1,245 Views)

This version of NI-Serial had an issue where the default wire mode setting may not be used when the port is opened, requiring you to set it again. This was fixed in NI-Serial 3.6. Once you update to your newer version of Windows and install a new version of NI-Serial, this problem should go away.

 

-Jason S.

0 Kudos
Message 4 of 5
(1,229 Views)

As you said it went away..

Message 5 of 5
(1,217 Views)