Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

open port fails while running labview

Hi,
I'm using LabView and serial port for communicate with a special Hardware. I take measurements with an oscilloscope (HP) and want to take screenshots to my testreports in Word. But this fails while if i run LV all serial ports are taken from LV and the Software for the Oscilloscope cannot access to the port. I use com2 for labview and com1 for the oscilloscope.
I know something about, that LV will take all serial ports under control if it run. But how can prevent this, so that LV will only take the port who is used by LV.
In the moment, i have to close LV before i take the screenshot. After that i have to close Word to can go further with test settings. And so on... Thats stupid.

Greetings from Gerhard and thanks for h
elp
Hardy
0 Kudos
Message 1 of 3
(2,936 Views)
Hi Gerhard,

Which version of LabVIEW are you using?
Which version of NI-VISA?

I just ran a test using LabVIEW 7.0 and VISA 3.01 and I had no problems using COM2 with another software while communicating on COM1 with LabVIEW.

Since I don't know which versions you are using, I can only give some global advice:
You should make shure that you have the most recent version of NI-VISA installed and you should use LabVIEW's VISA functions for serial communications (not the old serial VIs).
Furthermore you should properly open and close your VISA session. The shipping example LabVIEW <-> Serial.vi is a good resource to start from.

I hope this helps.

Richard H.
National Instruments
0 Kudos
Message 2 of 3
(2,936 Views)
Hi,

Thanks for help. I use LV6.1 with the driver who are shipped with. Because my software was startet at 1999, I use the old serial vi. I think it is a lot to do to change the hole program to visa.
I will do it at the next bigger revision of the program.

Thanks again
Gerhard
Hardy
0 Kudos
Message 3 of 3
(2,936 Views)