Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

ni 488.2 update 18.5 - GPIB-USB-B not supported and GPIB-USB-HS not talking

Solved!
Go to solution
Highlighted

Hello,

 

We've just updated our Windows 10 x64 DAQ machines to NI VISA 18.0 and NI 488.2 18.5. The machines were working fine with USB GPIB adapters using v 16 of the above.  Now we find that GPIP-USB-B are not recognized by windows ('Unknown device'), while GPIB-USB-HS is working properly in device manage, but show up as generic USB device, and not as GPIB adapter in NI-MAX

 

Please advise on a fix.

 

p.s. ni-max screen shot attached

0 Kudos
Message 1 of 9
(2,623 Views)
Solution
Accepted by topic author Fedor

Hi Fedor,

There seems to be two separate issues going on right now.

Firstly, GPIB-USB-B is not supported hardware for NI 488.2 for Windows 18.5. You can see all supported hardware at this link: http://download.ni.com/support/softlib//gpib/Windows/18.5/ReadMe.html#SupportedHardware

Secondly, I found a knowledge base article that addresses your issues with the GPIB-USB-HS and outlines a solution.
Link: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019LoOSAU&l=en-US

Hope this helps!

Message 2 of 9
(2,585 Views)

Hi pj,

 

I've uninstalled 18.5 version of 488.2 and installed 17.6. Now both adapters function fine. 

 

Thanks! 

0 Kudos
Message 3 of 9
(2,577 Views)

Hello,

 

I am having the same issue with the GPIB-USB-HS not showing the ability to scan for instruments. This is only true of version 18.5 of NI-488.2 and if I use version 17.6, the issue is not present. I read the knowledge base article, though this focuses on the idea that the incorrect driver was assigned by Windows for the device. In my case, the correct driver was assigned and there is still no option to scan for instruments.

 

Ideally, I would like to use version 18.5 as this comes with the NI Device Drivers 19.01 install package. Reverting to 17.6 would be a last resort.

 

Any thoughts or suggestions?

 

Thank you!

0 Kudos
Message 4 of 9
(2,379 Views)

nweng,

 

What I found that you have to use NI 488.2 v 17.6 or earlier, but it is compatible with latest NI VISA  and LabVIEW

0 Kudos
Message 5 of 9
(2,372 Views)

How does one uninstall 18.5?  I am having the same issue and cant seem to find the uninstall function.

0 Kudos
Message 6 of 9
(2,335 Views)

adrianP84,

 

Follow this: Uninstall NI Software on Windows 10 OS. Once you get the list of installed NI software, search for 488.2,

 

 

0 Kudos
Message 7 of 9
(2,321 Views)

@nicolas.pj wrote:

Hi Fedor,

There seems to be two separate issues going on right now.

Firstly, GPIB-USB-B is not supported hardware for NI 488.2 for Windows 18.5. You can see all supported hardware at this link: http://download.ni.com/support/softlib//gpib/Windows/18.5/ReadMe.html#SupportedHardware

Secondly, I found a knowledge base article that addresses your issues with the GPIB-USB-HS and outlines a solution.
Link: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019LoOSAU&l=en-US

Hope this helps!



Thank you for this solution. I was having the same problem with my USB GPIB and PCI GPIB busses using version 18.5. Going into services and starting the  NI GPIB Enumeration ServiceNI LXI Discovery Service, and NI Route Coordinator services as described in the article you provided is what fixed it. At first I was not allowed to start the services because when i clicked "start" a log on error appeared. This was fixed by right clicking the service, properties, log on tab, and changing to "log on as local system account". 

0 Kudos
Message 8 of 9
(2,184 Views)

To elaborate on nweng's reply, what I found about error (-37056 "counterfeit hardware"):

 

I found the problem occurs in driver ver 17.6 and up, after NI added a check for counterfeit hardware.  They removed all earlier versions from their site (for your convenience) since they didn't have this counterfeit check.  Since so many people report this flagging their GPIB-USB-HS box as counterfeit, even though they bought it directly from NI, it appears to be a software bug.  One guy even posted photos of his circuit board showing a custom NI logo-ed chip, so unlikely counterfeit.

 

Andrea W of NI Tech Support replied to my web complaint and said she would report it to their R&D team.  In the meantime, she uploaded ver 17.0 to their ftp site for me.  If like me, you may only need the 488.2 drivers (NI-MAX), not a full VISA setup.  Internally, NI refers to the setup as "17.0 488.2".  So, you will need go thru tech support to get this file.

0 Kudos
Message 9 of 9
(523 Views)