Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

lakeshore 331 temperature controller writing setpoint

Hello,

 

I am trying to interface with a Lakeshore 331 temperature controller via GPIB.  I was able to install the appropriate driver and simply read the temperature via the Instrument I/O Assistant.  I would like to of course control the temperature setpoint and heater power via labview as well.  However, when I select the write command I get a write input box in the Instrument I/O assistant box.  I tried to connect a numeric control to the "write" box.  However, I am still unable to write anything. 

 

Sorry if my question is too vague or simple.  I know pretty much nothing about labview.

 

Thanks a lot for your help. 

 

-Physicist

0 Kudos
Message 1 of 6
(5,858 Views)

Also, I get a response with the GPIB address number (12) when I 'ping' the device in MAX so I know it is communicating properly.

0 Kudos
Message 2 of 6
(5,851 Views)

You should also be able to use VISA Interactive in MAX to communicate with the instrument.

0 Kudos
Message 3 of 6
(5,838 Views)

Thanks for your response nyc.  Unfortunately, I am unable to read or write to the temp controller with VISA. 

0 Kudos
Message 4 of 6
(5,797 Views)
The driver you downloaded has nothing to do with the I/O Assistant. The assistant doors use VISA so I don't understand your comment about not being able read when your first post does say that you can read.

I would never use the assistant so explain the problem with using it for the write. Provide details on errors that you get and the details on the exact string you are writing.
0 Kudos
Message 5 of 6
(5,792 Views)

Hello,

 

I also face difficulty to connect lakeshore 331 temperature controller with RS232 port to a PC with USB port. I use an adapter to make the connection and the driver for the port is working well. I tried to communicate with the instrument via NI MAX. At first I got the following error VISA: (Hex 0xBFFF0072) The resource is valid, but VISA cannot currently access it. Later when I tried to send *IDN?\n command I got next error like this VISA: (Hex 0xBFFF0015) Timeout expired before operation completed. I use the port setting which is recommended in the device manual. Still I cannot solve the problem. 

0 Kudos
Message 6 of 6
(2,084 Views)