Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

can communicate with device in max but not in a labview program

Hi, I am trying to communicate with an acton monochromator 300i. 


When I use VISA, I can communicate just fine. When I try to use either of the labview examples (GPIB-VISA and GPIB-Labview) as well as my own program, I cannot, and I get a timeout error.


I have read a page about this kind of problem here:


It says, I should change the address of my device to 0.  (the default adress of my device is 11) .However I can only set the address of my device between 1 and 30, so this solution does not work for me.


I have tried using the property nodes to chand the termination charater settings, I have tried the commands with and without termination character (which is \r in this case), I have tried putting a delay between the write and read, I have tried reducing the "bytes to read" and  nothing has worked


Here is what the error says: 

Error -1073807195 occurred at VISA Open in

Possible reason(s):

VISA: (Hex 0xBFFF00A5) The interface type is valid, but the specified interface number is not configured.



Any help is appreciated.






0 Kudos
Message 1 of 6
It does NOT say to change the address of the instrument. It says to make sure the address of the controller is set to 0. This is something you do in MAX for the controller properties.

What is the exact VISA Resource Name? Is this an NI GPIB controller?
0 Kudos
Message 2 of 6

Hi, Thank you for your reply.


We have the national instrument PCI-GPIB bus. 


I believe the controller has the address 0 already from what I can tell. I have attached the screen shots of the MAX devices and interfaces tabs for GPIB. 


I am not sure what is meant by "Visa resource name"  but the name of the device shows up as GPIB11::11::INSTR. 

0 Kudos
Message 3 of 6

Sorry, I said I attached screenshots in my previous message but never did. so here they are:

Download All
Message 4 of 6
I don't understand how the controller would appear as GPIB11. Unless you have multiple controllers, it should be GPIB0. Can you rename it?
0 Kudos
Message 5 of 6

Yes, I can rename it. I have renamed it to GPIB0. Hoiwever the error is still there. 

0 Kudos
Message 6 of 6