Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Why do the NI VISA drivers (v20) crash on macOS and fail to load as a dylib?

UPDATE: I read the release notes on V20 and apparently MacOS 11.x is not supported yet.

 

I recently installed the NI VISA drivers (v20) on a MacBook Pro (2019) with Big Sur.

 

The NiMAX application crashes, and the VISA framework fails to load with various permission errors (usually related to RAID or highpointRR).

 

I can't pinpoint the exact date, but last year on Catalina with V19 drivers everything worked fine.

 

The NiMAX program pops the main window, then quits unexpectedly with a Problem Report window.

 

Compiling a simple C program to link to the 'visa.framework/visa' dylib results in:

 

"Error Domain=KMErrorDomain Code=71 "Insufficient permissions for action: Unable to load 'com.highpoint-tech.kext.HighPointRR' in unprivileged request." UserInfo={NSLocalizedDescription=Insufficient permissions for action: Unable to load 'com.highpoint-tech.kext.HighPointRR' in unprivileged request.}
Abort trap: 6"

 

Advice?

Download All
0 Kudos
Message 1 of 1
(171 Views)