Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Version conflicts between NationalInstruments,Visa and IVI.Visa in NI-VISA 17

Highlighted

Version conflicts between NationalInstruments,Visa and IVI.Visa in NI-VISA 17

A version conflict exists between NationalInstrument.Visa DLL revision 17.0.0.0 and the ivi,visa DLL revision 5.8.0.0.  Based on the AsmSpy output shown below, it seems that NI Visa was compiled against ivi.Visa 5.6.0.0 where ivi.Visa 5.8 is delivered with NI VISA 17.

 

Microsoft Windows [Version 10.0.15063]
(c) 2017 Microsoft Corporation. All rights reserved.

C:\Users\David>\\Fig\i\Pub\Applications\AsmSpy\AsmSpy.exe "C:\Program Files (x86)\IVI Foundation\VISA\Microsoft.NET\Framework32\v4.0.30319\NI VISA.NET 17.0"
Check assemblies in:
C:\Program Files (x86)\IVI Foundation\VISA\Microsoft.NET\Framework32\v4.0.30319\NI VISA.NET 17.0

Reference: mscorlib
4.0.0.0 by NationalInstruments.Visa
2.0.0.0 by NationalInstruments.Visa
Reference: Ivi.Visa
5.6.0.0 by NationalInstruments.Visa
Reference: NationalInstruments.Common
13.5.40.173 by NationalInstruments.Visa
Reference: System.Core
4.0.0.0 by NationalInstruments.Visa

 

Please advise.

 

 

 

0 Kudos
Message 1 of 3
(76 Views)

Re: Version conflicts between NationalInstruments,Visa and IVI.Visa in NI-VISA 17

Hi Davis,

 

Are you having a specific error after running your application? Can you attach the code and some screenshots of the error?

 

Regards,

Jose F.

0 Kudos
Message 2 of 3
(36 Views)

Re: Version conflicts between NationalInstruments,Visa and IVI.Visa in NI-VISA 17

No errors other than the compile warning below and a similar code analysis warning.

Adding assembly binding to the config file works around the issue. I wonder, though, if this is what NI expected and if a patch might be issued to address this feature.  

1> Consider app.config remapping of assembly "Ivi.Visa, Culture=neutral, PublicKeyToken=a128c98f1d7717c1" from Version "5.6.0.0" [] to Version "5.8.0.0" [C:\Program Files (x86)\IVI Foundation\VISA\Microsoft.NET\Framework32\v2.0.50727\VISA.NET Shared Components 5.8.0\Ivi.Visa.dll] to solve conflict and get rid of warning.
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets(1987,5): warning MSB3276: Found conflicts between different versions of the same dependent assembly. Please set the "AutoGenerateBindingRedirects" property to true in the project file. For more information, see http://go.microsoft.com/fwlink/?LinkId=294190.

0 Kudos
Message 3 of 3
(29 Views)