Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

VISA doesn't work on openSuse 10.2

VISA in annonced to be ok for Suse 10.2.
Actually, it doesn't work. We obtain the same error tant NI488.2.
Here is the message :

******************************** ERROR ****************************************
* Kernel source in /lib/modules/2.6.18.2-34-default/source does not appear to be
* configured for the 2.6.18.2-34-default kernel.
* Configuration of kernel source is required to continue installation. *
* Refer to the README file for the product you are installing for information *
* about configuring your kernel source. *
******************************** ERROR ****************************************

Installation aborted.


I installated the kernel package required by VISA :
kernel -source
kernel -syms

Maybe it's not enough ?!?
0 Kudos
Message 1 of 4
(3,267 Views)

Did you configure the kernelsource with

cd /usr/src/linux

make cloneconfig && make prepare-all

 

Message Edited by markus kossmann on 04-13-2007 04:57 AM

0 Kudos
Message 2 of 4
(3,262 Views)
That's a point. But I still have a problem concerning the kernel module compilation (Nikal).

Here is the message :

/usr/local/natinst/nikal/src make:
/bin/cp nikal.c objects/nikal.c
/bin/cp nikal.h objects/nikal.h
make -C /lib/modules/2.6.18.2-34-default/source SUBDIRS=/usr/local/natinst/nikal/src/objects modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.18.2-34 »

WARNING: Symbol version dump /usr/src/linux-2.6.18.2-34/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /usr/local/natinst/nikal/src/objects/nikal.o
/bin/sh: scripts/genksyms/genksyms: Aucun fichier ou répertoire de ce type
make[2]: *** [/usr/local/natinst/nikal/src/objects/nikal.o] Erreur 1
make[1]: *** [_module_/usr/local/natinst/nikal/src/objects] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.18.2-34 »
make: *** [objects/nikal.ko] Erreur 2
0 Kudos
Message 3 of 4
(3,241 Views)

HI.
your problem is due of your kernel version, suse 10.2 is not supported by NI. like you can see here.
your Error message is due to a bug of Mod.script in kernel 2.6.18, look on the NI web site, the last kernel version supported.

your not alone to have this problem like you can see in the attached file Smiley Very Happy.

but the only  solution to solve it at this time, is to downgrade your linux distribution version (and kernel to  the original kernel version).

Best regards
MobyJ..

0 Kudos
Message 4 of 4
(3,152 Views)