Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Vötsch VCL 7010 - ASCII-2 interface protocol

Solved!
Go to solution

Hi !
I have some troubles communicating with my Vötsch VCL 7010 climatic chamber.
I would like to control it via TCP/IP protocol in LabView, and here is the problem : I am sendind what seems to be the right strings of command, the chamber response is 0<CR> as it should be, and if I ask for a setpoint of 70°C I have a setpoint of 70°C.

But the oven doesn't want to start.

Here is exactly the string I send :
$01E 0050.0 0000.0 0000.0 0000.0 0000.0 0000.0 01000000000000000000000000000000 <CR>

Does anybody have any ideas on the subject, or is there anyone who is using this type of chamber and is able to communicate with it ?

Another odd thing : all my programs worked with the VT 4004, and the protocol is apparently the same...

Here is the datasheet :
http://forums.ni.com/ni/attachments/ni/140/44043/1/PROTOCOLE%20RS%20232.pdf

0 Kudos
Message 1 of 36
(6,127 Views)
You say exactly the string you are sending. You don't mean that you actually use '<CR>' instead of \r?
0 Kudos
Message 2 of 36
(6,115 Views)

No no, I am using the \r Smiley Very Happy

0 Kudos
Message 3 of 36
(6,109 Views)

What about the chambers bus id ? Are you sure that 1 is right ?

0 Kudos
Message 4 of 36
(6,086 Views)
Well I guess so, because informations are transmitted... (If I ask for the chamber's temperature, it gives me what I want)
In fact I have everything but the starting of the oven.
0 Kudos
Message 5 of 36
(6,082 Views)

Could it be that some reason (not a communication problem) doesn't allow the chamber to execute the start command ?

0 Kudos
Message 6 of 36
(6,077 Views)

A comparison with the Set nominal values for parameters command (interface protocol, page 9-12) shows that yours is incomplete :

 

$01E 0023.0 0050.0 0080.0 0000.0 0000.0 0000.0 0000.0 011 01010101010101010101010101010 <CR>   ---> interface protocol

$01E 0050.0 0000.0 0000.0 0000.0 0000.0 0000.0 01000000000000000000000000000000 <CR>                ---> your command

0 Kudos
Message 7 of 36
(6,073 Views)

I tried it already, and it's still not working Smiley Sad

0 Kudos
Message 8 of 36
(6,068 Views)

Hi,

 

did you find a way to make it work. I encounter the same problem right now Smiley Wink

 

BR

 

Felix Hoffmann

 

0 Kudos
Message 9 of 36
(5,759 Views)
Solution
Accepted by topic author MoonRat

Hi !
I finaly decided to use both protocols. According to the manufacturer, it may be because of the interface on this chamber (which is a bit different than the one I had on the VT 4004).
So I mainly use the ASCII-2 to read the values, stop the chamber, but I use ASCII-1 for setpoints, since the ASCII-2 can set the values but does not launch the oven...
I have a small library that works welle on my chamber, do you want me to give it to you ?

0 Kudos
Message 10 of 36
(5,736 Views)