Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Vötsch VCL 7010 - ASCII-2 interface protocol

Solved!
Go to solution
Highlighted

Hello, thanks for the help,

The issue is that even though I've set the command groups I don't get an answer, please look at the attachment below for the interrogation, that works, but when I try to set up the temperature and start the oven I don't get an answer. I've tried with seven command groups but with no luck. Since I have an answer with tera term I expect that command is received for the interrogation, the problem is with the E-string command. Can you please check if I'm sending the E-string command right? 

The communication wiring is done with DB9 from computer to chamber's motherboard Advantech x2 port. So I have 2 pins for rx/tx.

At one point I could start the cycles via command from the computer, but now for some reason it doesn't work.($01P0001<CR> is the command I've used).

Thanks a lot!

0 Kudos
Message 31 of 38
(419 Views)
Highlighted

Your E command string looks fine. Did the chamber start?

If not you should increase the groups number up to 14.

Anyway after an E command you should wait a little and send an “$01I<CR>” command to retrieve the chamber status. After chamber starts you will see in the response one or two digital values set with "1" value.

In my previous description I suggested to increase the group number permanently and to consider the case when themp chamber is started.

If starting with one group and repeat the command up to 14 groups and the chamber will not start, that means you have a communication problem.

You should check the serial communication parameters to be set in your program exactly with same values as them are selected in the chamber (baud rate, bits number, parity .....and so on...

Also use a "Straight or a "crossover" RS232 cable for the connection depending on chamber requirements.

0 Kudos
Message 32 of 38
(398 Views)
Highlighted

Hello, thanks for replying,

I have tried with 14 command groups but it still didn't work, the oven didn't start and didn't receive any response from the chamber. I have tried with a different baud rate but the only one that worked was 9600. In the capture you can see the serial port settings. 

As for hardware, I have 3 pins, tx-rx, rx-tx, gnd-gnd. Rx-tx was not twisted, I'm not sure if that makes a difference. For the realization of the cable I got in touch with someone from Advantech in order to get an RS232 port from the motherboard to the PC (DB9). I will try again what you have suggested with the 14 groups maybe I'll get lucky since I've twisted the cable rx-tx-gnd altogether. 

In the manual it is stated that for RS232 protocol I should have 9600/115200 baud, 1 start bit, 8 data bits, 1 stop bit, no parity, no confirmation.

Thanks! 🙂

0 Kudos
Message 33 of 38
(388 Views)
Highlighted

Hello, update,

I've manage to change the nominal temperature with the E-string, but the oven still doesn't start. I've only managed to start it with the program start command. 

One very important thing is that on the touch screen I've had to change the operation mode to external, otherwise I could only use the I-string command, and neither E-string command nor program command. 

I think that the only problem could be the digital inputs that need to be changed in order to start the oven, how I don't know.

$01E 0080.0 0000.0 0000.0 11101010101010101010101010101010<CR>  this is the E-string I've used to change the nominal temp. The response to this is 0, but you can also see on the touch screen/pad that the value has changed.

0 Kudos
Message 34 of 38
(384 Views)
Highlighted

Hello,

For negative values this is the E-string that works to change the nominal temp:

$01E -070.0 0020.0 0080.0 0100000000000000000000000000000<CR>

Message 35 of 38
(381 Views)
Highlighted

So it looks your command use 3 groups. The first group will represent the set temperature. To fill next two groups correctly you can use some parameters get from the device response to status interrogation (to avoid using 0000.0 values). Please try to set all 32 digital bits to 1 and see if it starts.

Be carefully because if I counted right in your negative temperature command you used only 31 digital outputs. It should be 32 I think. The digital bits number should be the same as in the status interrogation response. 

0 Kudos
Message 36 of 38
(344 Views)
Highlighted

Hello vesa.vlad,

 

Im also trying to use C# to communicate with the Votsch oven, can you please share your c# code as Im encountering some problems. Thank you

 

Regards

0 Kudos
Message 37 of 38
(190 Views)
Highlighted

-The oven does not seem to be responding to my requests, been trying since a while, cant get around  it

0 Kudos
Message 38 of 38
(185 Views)