Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Vötsch VCL 7010 - ASCII-2 interface protocol

Solved!
Go to solution
Highlighted

Hey,

 

I have the same problem as you, too. I'm trying to control a VTS 7060-5 via RS232 and the ASCII-2 protocol. It's even no problem to set nominal values of the temperature or the humidity, but I'm even not able to control the digital ports (especially I want to controll the "Start" signal too).

I have read a lot of posts so far and still got no clue what's wrong.

I  tried to change the control mode on the touch panel, but in every mode I was able to change nominal values via LabVIEW, but still not the digital ports.

 

 

Does anybody here found a cause or a way to handle it just with the ASCII-2?

 

And thank you for all the informations so far!

 

BR

 

Chris

0 Kudos
Message 11 of 38
(3,635 Views)
Highlighted

I got another question: How did you managed it to use both types of the ASCII protocol?

 

0 Kudos
Message 12 of 38
(3,602 Views)
Highlighted

The "Start" signal indicates if a cycle is running and can't be set directly with a specific command.

 

  • Start a cycle : $xxPyyyy<CR>
  • Stop a cycle : $xxP0000<CR>

with xx = address of the chamber and yyyy = number of the cycle

 

 

According to the protocol, there is no command to set the digital outputs. You have to configure them when editing the cycle (with S!MPATI).

 

I suggest you to contact Vötsch for further details.

 

 

0 Kudos
Message 13 of 38
(3,594 Views)
Highlighted

In the manual mode via Touchpanel I can set the digital channel "Start". Then the clima chamber starts heating or cooling according to the nominal value.

 

The string to set nomial values refering to the ASCII-2 protocol looks like this:

 

  • $01E 0023.0 0050.0 0080.0 0000.0 0000.0 0000.0 0000.0 011 01010101010101010101010101010 <CR>

So why should/can I send the state of the digital channels in the Edit-String, when I can't change them there?

That makes no sense for me.

 

I already contacted Vötsch with that question.

 

Thanks for your reply.

0 Kudos
Message 14 of 38
(3,590 Views)
Highlighted

I don't know why, but now my system works.

 

I contacted Vötsch and the Service gave me the clue to look up what my system is able to do by sending the string $xx?<CR>.

The systems output were examples for E- and I-Strings. I used the example of the E-String and it worked.

Afterwards I sent the string I was using before and it works too.

 

So I don't know what was wrong, but I works.

 

0 Kudos
Message 15 of 38
(3,549 Views)
Highlighted

Interesting. Thank you for the feedback.

0 Kudos
Message 16 of 38
(3,536 Views)
Highlighted

Dear Moonrat,

 

May I please ask you to share your library with me?

I am trying to control VCL 4010, VT37006 and VTV 4060 using ASCII-2 protocol.

But apprently the device does not want to respond to me.

 

Kind Regards

0 Kudos
Message 17 of 38
(3,179 Views)
Highlighted

I have the same problem, too.

My climatic chamber VT4021 didn't work with this string.

 

$01E 0050.0 0000.0 0000.0 0000.0 0000.0 0000.0 01000000000000000000000000000000 <CR>

 

After I set the Value for setting Fan speed to 100%, it will be work. 

 

$01E 0050.0 0000.0 0100.0 0000.0 0000.0 0000.0 01000000000000000000000000000000 <CR>

 

Kind Regards

0 Kudos
Message 18 of 38
(1,572 Views)
Highlighted

Hi,

 I am encounterig similar problems please help me also

0 Kudos
Message 19 of 38
(1,517 Views)
Highlighted

Because the original post is two years old, I would recommend making a new post for more visibility!

 

Thanks! 

0 Kudos
Message 20 of 38
(1,469 Views)