Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Unknown Command Error using NI-VISA to communcate with a 3rd Party Hardware by Ethernet connection

Hello,

 

We are trying to control a 3rd Party Hardware using NI-VISA. The charge has a driver, however in our application we want to deploy a VI in a RT Target (in this case a PXI) and, following a NI suggestion, is better to use NI-VISA (see "IVI Driver for 3rd Party Hardware"  in [1]).

 

The charge is controlled by Ethernet Connection and we get to established a connection without problems following the tutorial presented in [2]. The problem starts when we try to test commands. When we open NI-VISA Test Panel (in NI MAX) we get to make a query unsing "*IDN?\n" command, but any order command gives "Error: Unknown Command" response.

 

After this error appears the first time even "*IDN?\n" stops working giving the same response "Error: Unknown Command" when we use query.

 

The same error happens when we try to control the 3rd party hardware direct using a VI in LabView and the "*IDN?\n" command does not work a single time when executed by this VI. A print of the VI mentioned in this paragraph is anexed.

 

[1] https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019PmbSAE&l=pt-BR

[2] http://www.ni.com/tutorial/3325/en/

0 Kudos
Message 1 of 4
(1,568 Views)

Hello, marcelo.

 

Could you maybe tell me more about your system so I can try and help you?

  • What is the 3rd party hardware you're trying to control? 
  • What are your LabVIEW and NI VISA versions? What's your OS?
  • The tests you described were performed in a computer or directly in the PXI? Have you tried using a different computer?
  • Can you test this 3rd party item separately to make sure it's reading the commands correctly?

Hope to hear from you soon.

 

Best Regards,

 

 

Lígia T. Ferreira
Technical Support Engineer
National Instruments Brazil

0 Kudos
Message 2 of 4
(1,532 Views)

Hello, Lígia. Thanks for your reply.

 

1) The instrument we are trying to control is a NHR 4700 DC Load [1]. It has its own IVI driver, that works correctly when we attempt to control it with the computer. It also has a labview control interface made by the manufacuturer, to be used on a computer, which works correctly too.

 

2) We are currently using LabVIEW 2015 SP1 on a laptop with Windows 7. We've also tried with LabVIEW 2018 on a laptop with Windows 10 and encountered the same issues.

 

3) All the tests were performed in a computer directly. We wanted to see if the NI VISA would work, prior to attempting a test with the PXI. We've tried with two different computers.

 

4) We've also tested the instrument by sending the SCPI commands via a HyperTerminal on a third pc with Windows XP, and it worked. So far, the reported issues have only been found when we were testing the commands in labview or the visa test panel in NI-MAX.

 

If you have any more questions don't hesitate to ask. Thanks again for you help.

 

King regards,

Marcelo

[1] https://nhresearch.com/power-electronics-test-systems-and-instruments/ac-dc-electronic-loads/dc-load...

0 Kudos
Message 3 of 4
(1,523 Views)

Was this issue ever resolved ?

0 Kudos
Message 4 of 4
(223 Views)