Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Unexpected CIC errors

Solved!
Go to solution
Highlighted

Hi,

 

We recently bought several new DELL Optiplex PC's. Those PC's are using Windows 7, 64-bit, in combination with a National instruments PCI-GPIB card.

We are currently using version 2.8 of the NI-488.2 library.

All these PC's are used to communicate with different GPIB devices for an automated measurement.

One of the PC's is however raising unexpected and intermittent GPIB CIC errors (Controller In Charge), during the communication with the devices.

The same automated measurement program is also running on other PC's but on those PC's the CIC error is not triggered.

 

This problem is not specific for the communication with a specific device, it happens randomly with different devices. Also the interval between the errors is random.

When the NI-SPY program is not running, the CIC error can occur within 5 minutes, but when the NI-SPY program is running, the CIC error only happens once in a day.

So the problem seems to be time-related, as we know that the NI-SPY program is introducing a small delay.

 

See the attached NI-SPY file for an example. It shows that the CIC error is triggered during communication with the devices, without any specific reason.

And the error situation seems to be cleared 20 milliseconds later, because the next GPIB command doesn't raise the CIC error anymore.

 

The question at this moment is:

- Is something changed in NI-488.2 version 2.7 or version 2.8, that could have introduced this problem?

- Are other people also observing this CIC error?

- Does anyone have a suggestion or solution for this problem?

 

Thanks in advance, Joro.

0 Kudos
Message 1 of 3
(1,439 Views)
Solution
Accepted by topic author joro

Hi

When it is timing related it is maybe an option to delay the speed on the bus.

In MAX you can set the bus timing to 2 microseconds. Normally only needed for old equipment but in this case a test if things go better.

greetings from the Netherlands
Message 2 of 3
(1,434 Views)

Hi Albert,

 

Thanks for the suggestion of changing the bus timing to 2 microseconds.

 

On the problematic PC (the first PC), the bus-timing was set to 500 nanoseconds. After I changed it to 2 microseconds, we didn't see the CIC errors anymore.

This morning we also saw the same error (unexpected CIC errors), on one of the other new PC's (a second PC), where we didn't see them before. This is explainable, because it is very probably related to a measurement device that was moved from the first PC to the second PC.

Also on the second PC the bus-timing was set to 500 nanoseconds, and the CIC errors occured several times within a short period.

After I changed the bus-timing to 2 microseconds on the second PC, also on that PC the CIC errors did NOT occure anymore within the next hour.

 

So the conclusion at this moment, is that it is certainly helping that the bus-timing is increased to 2 microseconds.

 

Thanks.

 

0 Kudos
Message 3 of 3
(1,415 Views)