Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Unable to load gpibtsw (Centos 7)

Hello everyone I am trying to install the NI-488.2 on my Centos 7.9 machine. I got the latest drivers from the website version 17.0 and I am trying to test the install by using gpibtsw as listed in the README file but I keep running into missing file or directory issues and was hoping I could get some assistance on this.


The labview runtime engine was provided as part of the driver install, but I installed the latest version from the NI website, but still no luck unfortunately. 

0 Kudos
Message 1 of 4

Hi Mo, 

Looking at the error in the screenshot you attached, you require version 2015 of the LabVIEW Runtime Engine, rather than the 2017 version you have installed. The download link is given to you in your error, so please try downloading it, and go from there.
This 2015 version of LabVIEW Runtime is compatible with versions 15.0-18.5 of the NI-488.2 Driver, so please ensure that you have downloaded either version 17.6 or 18.5 from the website. The latest version (20.0) will not be compatible. 

Good luck! 


0 Kudos
Message 2 of 4

Hi Alice,

Sorry for the lateness in my reply and thank you for getting back to me. I tried your solution, but unfortunately I am still having issues with the NI drivers. 


I downloaded the 2015 64 bit LabVIEW Runtime Engine along with the NI-488.2 Driver version 17.0 as that was the only one available to me for Linux and I'm still getting a similar kind of error, but now the error message is referring to a different missing file . 


I've attached a new screenshot for your reference.


In addition to this, are there any commands I can use to identify what version is currently installed on my Centos environment? We have other systems that are working fine, but they are old and It would be nice to see what version of the NI-488.2 drivers or LabVIEW Runtime Engine is running on them.


Kind Regards,


0 Kudos
Message 3 of 4

Hi Mo, 


I have taken a look and there was someone else who faced a very similar issue which can be seen on the forums post: Is this a VISA Bug/User Error/Other? (NI-VISA16.0.0 on Scientific Linux 6.8).


The key feature appears to be installing, which appears to be a Linux file- please have a go and let me know if you have further issues with it! 


In terms of finding out which version of the NI software you are looking at please take a look at the article: Determine the Version of the NI Software Installed on My Computer. There is a Linux section further down the article which I believe should answer the question. 


Good luck, 


0 Kudos
Message 4 of 4