Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

USB-8451 -- No signs of life



I have a USB-8451 that I've been using the past few days that stopped working... it came up with an error (I'm not sure what, unfortunately) saying something to the effect of the communication with the device being lost.


Here is what I know for sure:

1) I've tried different USB ports.

2) I've rebooted the computer.

3) I've tried different computers.

4) LED does not light whatsoever.

5) Does not appear in device manager (Windows 7)

6) Does not appear in Measurement & Automation Explorer.  I have the 2.1 NI845x driver.

7) When ni845xFindDevice() runs, I get error -301701 NI-x845x: The resource name contains insufficient information, describes a resource that is not present in the system, or describes a resource that may be in use by a serparate process.

😎 I get the same error when it isn't even plugged in.
9) I was using SPI at the time when this occurred.
10) I was using the 5V output when this occurred.


I'm fairly concerned this thing is dead.  What else can I try to investigate this further?

0 Kudos
Message 1 of 5

It is dead. the USB device is "Tango Uniform (TU.)"   What is the device on the on the other end?

"Should be" isn't "Is" -Jay
0 Kudos
Message 2 of 5

@JÞB wrote:

It is dead. the USB device is "Tango Uniform (TU.)"   What is the device on the on the other end?

The devices I'm controlling are SPI-controlled microwave/RF devices.  They each worked individually with this USB-8451.  I was trying to use them both together with different chip select lines when it stopped working.  At first when they were both connected it was controlling one of them correctly, but sometime when I was attempting to control the other one (on CS1 instead of CS0) the connectivity was totally lost.  And yes, it seems to have died.


Would anyone recommend I try anything else?  It seems like some sort of hardware problem.

0 Kudos
Message 3 of 5

I had very similar case with NI-8451. I should say the exactly the same case.


Sudenly it had stopped working.


I was contolling mmWave unit thru SPI.


And sudennly - no response.


It looks like they are not awesome...

0 Kudos
Message 4 of 5
Let me guess. the minicircuits knockoff of the peeigrin 4306 actuator?

"Should be" isn't "Is" -Jay
0 Kudos
Message 5 of 5