Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

USB-232/2 shows COM ports but no VISA resources found!

Go to solution



I'm using a NI USB-232/2 interface to connect my OMEGA Engineering temperature controller to computer. The temperature controller is communicating with computer via hypertermianl and the configuration software from OMEGA, but can not be detected by NI MAX. I attached a screenshot of my NI MAX. I could see both COM ports, but I can't do see the VISA test panel. 


My problem is similar to the post NI USB-232 problem!!! I tried the solution to uninstall and re-install both the NI VISA and NI Serial, but still not working. 


NI Labview 2009

NI MAX 5.6.0

NI Serial version 4.0

NI VISA version 5.4.1

Temperature Controler: Omega engineering CNi1644-c24


Have been talking to NI application engineer for two days, no solution yet. Anyone can help? Thanks!!!





NI-MAX Screenshot.JPG

0 Kudos
Message 1 of 19

It is definately an NI-VISA installation issue.  The information being shown in MAX is only what the NI-Serial driver is returning.  You may want to try doing a repair on NI-VISA from add/remove software.


You may also want to try resetting the MAX configuration from the tools menu in MAX.

0 Kudos
Message 2 of 19

You might also want to ensure that none of the COM ports are open or in use when you launch MAX.  The only other thing that I can think of is trying to right-click and launch MAX as admin, but honestly that shouldn't be an issue.

0 Kudos
Message 3 of 19

If the device is working with hyperterminal, windows is ok.

My question is do you see the com ports in VISA or MAX?


The instrument never is visible, only the comport.

I have the feeling that you want to find the instrument, is that correct?

greetings from the Netherlands
0 Kudos
Message 4 of 19

Hi JoshuaP,


Thanks. I tried to repair the NI-VISA, and also resetting the NI MAX configuration. "No VISA resources found" error message is still there.  I was using the admin account to log in the NI MAX. Do you have other further suggestions? The labview is connected to an impedance analyzer HP4194A via GPIB. It was working fine. 



0 Kudos
Message 5 of 19

Hi Albert.Geven,


I'm aware that the COM port may not see the instrument. But the COM port should be able to be used as a VISA source. When I left click the COM port in NI MAX, I won't be able to see the VISA test panel on the right side of the window. If I try to run a basic serial write and read vi, in the drop down menu of the VISA resource name, I couldn't see the COM port I have my instrument connected to. 


I have uninstall and re-install the NI Serial and NI Visa twice, problem still there. Please let me know if you have any suggestions! Thanks.



0 Kudos
Message 6 of 19

Have you installed any other suppliers VISA Layer? (Agilent IO Library has its own VISA) During the installation have you come across any message or Error? 

0 Kudos
Message 7 of 19

The Labview program for HP4194a is set up by someone else long time ago. I remember when I was installing the VISA, the software did ask me to rename of of the visa with Agilent name, so I believe th. Do you think the Agilent VISA could cause conflict with the serial connection?

0 Kudos
Message 8 of 19
There is absolutely no reason to install Agilent VISA. Remove it. You want NI-VISA to be the sole and primary if you are using LabVIEW. Installing NI-Serial is also a waste unless you have an NI serial device.
0 Kudos
Message 9 of 19

Hi Dennis,


The Agilent impedance analyzer labview program is set up by others long time ago. I'm concerned removing the Agilent Visa I/O library will compromise the impedance analyzer communication. And I do need the Serial Driver. I purchase the USB-RS232 from NI, and my problem here is how to connect the temperature controller through RS232, and get it communicating with labview. Please let me know if you have any advice. Thanks. 

0 Kudos
Message 10 of 19