Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Timeout Error when using NI GPIB-USB-HS with Laptop to Yokogawa AQ6370C

Solved!
Go to solution

Hi everyone, 

 

I am having difficulty communicating with a Yokogawa AQ6370C optical spectrum analyzer. I want to do this via a NI GPIB-USB-HS from the instrument to my laptop. I am able to find it on NI MAX, but I am unable to control my instrument. I have done a million things to try to troubleshoot this problem, with no luck. 

This list includes:

1. Reinstalling NI-VISA and 488.2

2. Yes, all of my software drivers, etc are compatible (using the charts on the NI site)

3. Changing "timeout" in I/O settings to 30 seconds (pic 3) as instructed by the OSA's manual (pic of these instructions included just for fun- pic 6)

4. Checking if the instrument needs termination characters. The remote control manual does not even mention the phrase "termination characters," so I am assuming this is a no. Also, I tried them anyways just in case - no luck. 

5. I set the I/O protocol to high speed since I have a new HP Precision laptop, and one NI FAQ said this could be an issue some how ??

6. When I first click on my instrument from the NI MAX list of connected devices, it states "The instrument did not respond to the *IDN? command. Refer to the instrument's programming manual to determine if this command is supported." (see pic 2), but the manual says this is a compatible command.

7. The device status says the device is working properly (pic 7).

8. The NI GPIB-USB-HS is connected to port 1, like it instructs in the manual for PC remote control. 

 

No matter what I try, I keep getting this error (pic 1).

 

Any help is greatly appreciated as I've been working through this for 2 days now. 

Thanks so much!!

 

1

OE2_3-1614636394888.png

2

OE2_5-1614636828947.png

 

3

OE2_2-1614636255520.png

 

4

OE2_1-1614636196223.png

 

5

OE2_0-1614635971427.png

6

OE2_4-1614636620027.png

7

OE2_6-1614637008298.png

 

0 Kudos
Message 1 of 6
(369 Views)
Solution
Accepted by OE2

Hi

My first step would be to set gpib speed to 1 microsecond instead of high speed.

Not all instruments are high speed. And depending on distance and total number of instruments with several gpib cables I also would bring the speed down.

 

If things are working in low speed I would try higher speds only if needed.

greetings from the Netherlands
Message 2 of 6
(328 Views)

Hi, thanks for the reply. Where would I set it to 1 microsecond?

 

I tried putting it in both "normal speed" and "high speed" under the I/O protocol in the I/O settings tab. I got the same error in both instances. Thanks!

0 Kudos
Message 3 of 6
(321 Views)

This unit has two GPIB connectors on the back.  Depending on how this is being used will determine which port is to be connected.  According to the manual, GP-IP2 will NOT respond to SCPI commands/queries.  See section 1.1 in the manual.  Additionally, you will need to ensure that the 'LF' character is appended to each command/query.

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
Message 4 of 6
(316 Views)
Solution
Accepted by OE2

Good catch Minions.

 

But to answer the timing question

In the GPIB settings under advanced you find bus timing.

Slowest is 1 microsecond, my default in the picture is 500ns.2021-03-02 18_37_41-NI GPIB-USB-HS _GPIB0_ - Measurement & Automation Explorer.jpg

greetings from the Netherlands
Message 5 of 6
(308 Views)

Thank you so much!!! Setting it to 1 microsecond worked. Here is my new settings for those who have the same issue. I appreciate everyone's help!

 

OE2_0-1614712244985.png

 

0 Kudos
Message 6 of 6
(301 Views)