Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

There is no NI-VISA for linux at the download page

Solved!
Go to solution

Hello,

 

I trying to find the NI-VISA for Linux, however that option is not available on the page http://www.ni.com/pt-br/support/downloads/drivers/download.ni-visa.html#305862

 

Where is the link to download that version?

 

Best Regards,

Lucas

0 Kudos
Message 1 of 8
(4,429 Views)
Solution
Accepted by topic author lucamedeir

Hi Lucas,

 

You can download Linux device drivers (which includes VISA) here:

 

NI Linux Device Drivers Download
https://www.ni.com/en-us/support/downloads/drivers/download.ni-linux-device-drivers.html

 

Here is some additional information you may find useful:

 

Downloading and Installing NI Driver Software on Linux Desktop
http://www.ni.com/product-documentation/54754/en/

Levi D.
Technical Support Engineer
National Instruments
0 Kudos
Message 2 of 8
(4,390 Views)

Thank you for your answer, Levi.

 

 

0 Kudos
Message 3 of 8
(4,382 Views)

Why can we not download NI-VISA of whatever version for the supported linux distros?  I don't understand why it's not available from the overall NI-VISA download page, and i also don't understand why everything is being redirected to that download site when there's no ability to download NI drivers for linux from it.

What happens if we need NI VISA 16 or 17?  We can't get those from the NIdrivers packages.

0 Kudos
Message 4 of 8
(4,337 Views)

In 2018, we implemented a major change to the way that National Instruments' driver software is acquired and installed onto a Linux Desktop system. Software after this change cannot be installed on a system with software before this change already on it, so older versions are not currently able to be downloaded online. The current system downloads a .zip file of supported drivers in a software package so these files currently have their own download page. R&D (who owns the driver download pages) monitors the Idea Exchange and welcomes new ideas/feedback from our community. 

 

Should you need an older version of a specific driver, you will need to reach out to NI Support to request the specific driver version. 

Levi D.
Technical Support Engineer
National Instruments
0 Kudos
Message 5 of 8
(4,324 Views)

Hi Levi,

 

How can I install the download  NI device driver? 

I used the command:  alien -i ni-software-2019-19.2.0.49152-0+f0.lp150.noarch.rpm

 

the error is given below: 

 

dpkg --no-force-overwrite -i ni-software-2019_19.2.0.49152-1_all.deb
(Reading database ... 166138 files and directories currently installed.)
Preparing to unpack ni-software-2019_19.2.0.49152-1_all.deb ...
Unpacking ni-software-2019 (19.2.0.49152-1) over (19.2.0.49152-1) ...
dpkg: error processing archive ni-software-2019_19.2.0.49152-1_all.deb (--install):
trying to overwrite '/etc/zypp/vendors.d/ni.conf', which is also in package ni-software-2018 18.0.1.49153-1
Errors were encountered while processing:
ni-software-2019_19.2.0.49152-1_all.deb
Unable to install at /usr/share/perl5/Alien/Package/Deb.pm line 97, <GETPERMS> line 5.
find ni-software-2019-19.2.0.49152 -type d -exec chmod 755 {} ;
rm -rf ni-software-2019-19.2.0.49152

0 Kudos
Message 6 of 8
(3,964 Views)

Hello, which Linux distro are you using? I tested Centos 7 and SUSE Leap 15.0 ( (installation command is: rpm -i ....) successfully. My only problem is that when I run Matlab R2019b, I'm getting "the specified vendor adaptor couldn't be found" error. I don't know whether this is a Matlab issue or an NI VISA issue in the Linux environment.

0 Kudos
Message 7 of 8
(3,895 Views)

Hi Levi, 

 

I am looking to control some visa instruments through Linux, I understand that there is support for most of the ni-* packages on ubuntu now except ni-visa. Do you know whether this will change soon? 

 

Barnaby

Message 8 of 8
(937 Views)