Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

The following error is generated when trying to control my multimeter and powermeter: -1073807339

I use Labview to control three instruments: powersupply (DC voltage mode) of Agilent E3643A, multimeter of Keithley 2000, and powermeter of EXFO PM-1600, all of which are connected to computer with GPIB cables. Things go on well when I first only control the powersupply and the multimeter for work, leaving the powermeter turned off, but as I turn the powermeter on, the following error occurs:

ERR(-1073807339)
VISA wait on Event in Wait for RQS.VI:1 --> Keithley 2000.lvlib: Wait for SRQ.vi --> Keithley 2000.lvlib: Data Read Single --> my file name

Here "Keithley" refers to the multimeter. I try this several times and discover that though the powermeter is also connected two the other two instruments with GPIB, as long as it is turned off, there won't be problems, but if it's on, the program won't work and the above error will be reported.

I also write another program to control the powersupply and the powermeter to work together. It works well. So I think the problem lies inbetween the powermeter and the multimeter, though I don't know what exactly the problem is, or how to solve the problem. My experiment requires the three instruments to work together. I do tried to write another program for it yet it didn't work as expected, and the same error was reported. I need help from you, thanks a lot.

0 Kudos
Message 1 of 13
(3,991 Views)

Sounds to me that you have a duplicate address. In MAX when you scan for instruments, do you see three separate ones listed? The scan for instruments is the very first step you need to do.

0 Kudos
Message 2 of 13
(3,987 Views)

Yes I checked the IP address of the three instruments. Agilent E3643A Powersupply is 6, Keithley 2000 Multimeter is 16, and EXFO PM-1600 Powermeter is 20. It looks that there are no conflicts.

0 Kudos
Message 3 of 13
(3,979 Views)

An IP Address is completely different than a GPIB address. What you are showing is the GPIB addresses.

 

What about my question? When you did the scan, did three separate instruments get listed? I don't know if you checked the addresses by doing a scan or by just reading the address from the instrument.

0 Kudos
Message 4 of 13
(3,975 Views)

Oh I see them listed in the MAX. There are three separate ones. I read the GPIB address from there.

Sorry for confusing you.

0 Kudos
Message 5 of 13
(3,963 Views)

Then perhaps there is a physical problem. One of the instruments is asserting a control line or there is a defective cable someplace. Perhaps you get the error only with the Keithley because the program does not check the RQS of the Agilent. I kind of doubt if there is anything wrong with the code. In the past, what I've done to try to fix similar problems is to replace the cables and to swap out the different instruments.

0 Kudos
Message 6 of 13
(3,959 Views)

Hi Epohym, 

 

I am facing a similar problem with different set of devices.

Did you find a solution to your problem?

If you can share, it will be of great help to me as well.

0 Kudos
Message 7 of 13
(3,653 Views)

Hi,

Unfortunately I did not find a solution. I way I solve the problem is to change the instrument I used.

Good luck,

0 Kudos
Message 8 of 13
(3,630 Views)

Thanks.

 

0 Kudos
Message 9 of 13
(3,628 Views)

Hi shals,

 

Can you give us some more details on what you are seeing?  Are you also using three instruments?  Is the behavior only with one of them?

 

 

Regards,

Hassan Atassi
Senior Group Manager, Digital Support
0 Kudos
Message 10 of 13
(3,592 Views)