Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Testing connection to MD-CC4 USB RS422 for a mdrive stepper motor made by Schneider

Thanks so much! Will attempt this first thing tomorrow afternoon and will update you. 

0 Kudos
Message 11 of 21
(142 Views)

I have attempted to run the VI and an error did output. The error was -1073807298 (Hex 0xBFFF003E). I looked online and it seems to be an error due to other processes using the I/O ports of my device. I closed all application that may use that port and reattempted it and I still get that error. I have attached an image. Also, I have attached the subvi that you asked for as well. 

Download All
0 Kudos
Message 12 of 21
(132 Views)

Hi

What is probably missing is the initialization of the port.

I found the following (not so beautiful construct) in seq 0 of your program.

2021-02-11 11_01_05-Motor_and_Stage_Control cal.vi Block Diagram _.jpg

 This can better be replaced by the attached vi.

Build in a new vi the two vi's together as in this picture. I don't send you an implementation to get you test it yourself.

 

The wrong parts in the original is the use of local variables where that is not needed at all.

Instead of filling in a wrong COM6 the VISA resource name should be connected to the initialize vi.

And instead of filling a string with comment, this should have been the default value of VISA resource name. Now everybody has to change the code to get this running. So filling in COM4 is not sufficient.

 

Use both new subvi's the former had no connector connected.....

2021-02-11 11_18_32-Untitled 2 Block Diagram _.jpg

 

greetings from the Netherlands
Download All
0 Kudos
Message 13 of 21
(127 Views)

Sorry 

I did send version LV2020, should be LV2013

Here they are

greetings from the Netherlands
Download All
0 Kudos
Message 14 of 21
(126 Views)

What is the difference between the Open VISA.vi and the Initialize motor.vi. Sorry I am still new to LabView and trying to understand all the components.

0 Kudos
Message 15 of 21
(115 Views)

Open VISA sets the serial line in the correct "mood".

Initialize motor sets the motor in a known state.

greetings from the Netherlands
0 Kudos
Message 16 of 21
(102 Views)

I still unfortunately still get the same error using the vi's you have uploaded. I closed all applications that was making calls to the port. I even disconnected the power supply and the USB and I still get that error.

 

0 Kudos
Message 17 of 21
(91 Views)

VISA: (Hex 0xBFFF003E) Could not perform operation because of I/O error.

 

The error just signals an IO error. This also can mean that the port is not opened at the correct baudrate or even that com4 or com6 are not correct. First step is to check if that error occurs in the open or in the first write. Anyhow your RS422 device should be found also in the windows device manager and needs probably more settings than just a buffer size setting.

 

Anyhow I now realize that I don't know the motor specification only the spec of the serial usb driver.

 

So what motor system are you talking to?

greetings from the Netherlands
0 Kudos
Message 18 of 21
(89 Views)

Hi,

Sorry for late reply! The motor is a "MDRIVE 23 motor driver plus by Schneider". The motor comes with an already installed software which is an IMS terminal. I used that terminal to successfully communicate to the motor with the same rs422 usb but it isn't able to communicate with the labview. 

0 Kudos
Message 19 of 21
(67 Views)

Also, I believe the error only occurred on the WRITE vi because I don't recall seeing any errors when I ran OPEN vi

0 Kudos
Message 20 of 21
(60 Views)