Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

SOLUTION: Keysight 82357B with TestStand Automation

I figure something I learned from using the Keysight (Agilent) 82357B GPIB-USB Adapter with NI is worth posting just in case someone can be helped by it. I know the first question will be "why not use NI..." when the answer is we are trying to use the hardware we have and cannot always justify dropping money on new equipment.

The first problem I encountered was fixed with the Use Keysight (HP Agilent) GPIB Devices with NI Software article and well understood. But I still had problems talking to my Keysight 34970A. Frequently the device would error out with a 550 error stating it cannot accept a remote command in local mode. The device would drop out of Remote mode and my VI's would timeout, thus freezing TestStand until they responded. I could write it up to work around that but in the end I still would pile up with errors on the equipment and increased test time, so I tried looking into what might be the core problem.

Turns out, there isn't much online regarding this situation. Long story short, the USB-GPIB adapter isn't maintaining the Remote Mode of the device which may or may not be directly related to using a 3rd party (NI-VISA, NI-MAX) driver. A quick and dirty solution to this was to short the REN line of the GPIB cable to GND so that upon first remote command the mode would be toggled but couldn't go back to local without a key press on the front panel. GPIB Pinout can be found here. 

I know that this still isn't a professional solution but thus far our repeatability of the test is better than a software work-around and avoids overhead of auto-retrying VI's/commands on a test that can take up to 45min already.



Note: I did try this on both Win XP and Win 7 and also tried IO Libraries 16, 17, 18 as well as NI-MAX latest versions. I couldn't see this problem being specifically 1 configuration as it occurred across multiple revisions of those applications and drivers.

Any thoughts feel free to add.


0 Kudos
Message 1 of 2


Could it be due to the power settings for USB devices. Check if windows is allowed to save power on usb devices.

This could result in powerdown/power up and in that way loose the remote status.

greetings from the Netherlands
0 Kudos
Message 2 of 2