Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Resource Conflict with NI PCI-485/8

I am having a problem with resource conflicts for an NI PCI-485/8 port on my computer that runs Windows Server 2000.

 

In the Device Manager window I find that:

 

COM3  - COM 6 give the following conflict message:

 

Input/Output Range ACC0 - ACFF used by:

NI PCI-485 SN:DF28AB, Communications Port 8 (COM10)

NI PCI-485 SN:DF28AB, Communications Port 7 (COM9)

Memory Range DEEFFC00 - DEEFFC7F used by:

NI PCI-485 SN:DF28AB, Communications Port 8 (COM10) 

NI PCI-485 SN:DF28AB, Communications Port 7 (COM9)

 

From COM9 is get this message:

 

Input/Output Range ACC0 - ACFF used by:

NI PCI-485 SN:DF28AB, Communications Port 8 (COM10)

NI PCI-485 SN:DF28AB, Communications Port 6 (COM8)

Memory Range DEEFFC00 - DEEFFC7F used by:

NI PCI-485 SN:DF28AB, Communications Port 8 (COM10) 

NI PCI-485 SN:DF28AB, Communications Port 6 (COM8)

 

And from COM10 I get this message:

 

Input/Output Range ACC0 - ACFF used by:

NI PCI-485 SN:DF28AB, Communications Port 7 (COM9)

NI PCI-485 SN:DF28AB, Communications Port 6 (COM8)

Memory Range DEEFFC00 - DEEFFC7F used by:

NI PCI-485 SN:DF28AB, Communications Port 7 (COM9) 

NI PCI-485 SN:DF28AB, Communications Port 6 (COM8)

 

I tried to fix the problem by disabling all the ports but one and communicating with the instrument and it still did not work. I also tested to see if the port was working by using Hyperterminal and I also could not communicate with the instrument.

 

The final thing I tried was to use the existing serial port on the computer to communicate with the instrument through Hyperterminal and that was successful.

 

I am not sure what else I should do. Any help would be greatly appreciated.

 

0 Kudos
Message 1 of 2
(2,605 Views)

Try going into Device Manager, selecting one of the COM ports that has a conflict, right click, select properties, click the Resources tab, uncheck the Use automatic settings option, and see if you can change the Settings based on: dropdown menu box to choose an option that is not in conflict.  If there are no options that are not in conflict, see if it lets you Change the settings of any configuration options by clicking the Change Settings... button.

Jensen
National Instruments
Applications Engineer
0 Kudos
Message 2 of 2
(2,558 Views)