Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

RS-485 /Wire2-EchoDTR loopback example - Error -1073807330 occurred at Property Node (arg 1)

Hello,

 

Im trying to check if my USB to serial RS485 converter (Digitus- DA-70157 FT232RL based) is working. When i used RS232 i could perform simple loopback test in Realterm/hyperterminal/Br@y++ Terminal

 

I read that something like this is not possible with RS485? I found example at NI site

http://digital.ni.com/public.nsf/allkb/D5CC369B3E3E6F0586256D1600563245

 

Im looking at "Two-wire Echo (non-Auto) Mode"

 

I connected my USB to serial converter to USB (using latest FTDI drivers 2.12.0.0, i can see new USB serial port in device manager under COM3). I prepared a loopback connector just like in article above (both socket and plug pins are numbered so i double checked they are right, i also tested connectors to see if singal can pass).

 

I downloaded VI attached to article above. Fresh from the page, no modifications. I open it (lab view 14.01 32bit and i downloaded what seems to be newest Ni Visa drivers from October 2014 http://www.ni.com/download/ni-visa-14.0.1/5023/en/ my operating system is windows 8.1 64 bit)

 

Then i configure Visa serial connection to match settings in device manager:

Baud rate 9600

data bits 8

parity none

stop bits 1

flow control none

delay before read 500

And of course most important i pick Visa resource name COM3 (i checked it against my device manager and USB to serial convered does indeed appear under COM3)

 

I type in string to write "test" and..... no matter what i do it ends up with error:

 

"Error -1073807330 occurred at Property Node (arg 1) in 485 Loopback Test 2 Wire Echo.vi

 

Possible reason(s):

VISA:  (Hex 0xBFFF001E) The specified state of the attribute is not valid, or is not supported as defined by the resource."

 

It happens if write is On and read is Off. It also happens if write is Off and read is On and happens when both read and write are off aswell. It also happens if the string to write is default "*IDN?\r\n"

 

The only thing i figured out is that if i delete first property node "wire mode" the progam will execute without errors but i seems that it does nothing, string to read is empty.

 

 The exact same thing was happening at other computer (with older labview and older ni-visa drivers) and i thought its because of not up to date drivers thats why i tried other computer with stuff that is up to date.

 

I did thing you do every time something goes wrong:

- i tried unplugging and plugging converter again,

- i checked other USB ports and i tried plugging converter directly into USB (no additional cables)

- i tried restarting my computer and labview

and the error above still haunts me.

0 Kudos
Message 1 of 3
(4,732 Views)

Hey KonradIC,

 

 

 

                              It would be useful if you could try the Highlight Execution mode in LabVIEW, and determine exactly what is the property node at which the error occurs. This should give us a better idea.  

 

                             Also, could you point out from where did you download the drivers ? You have mentioned that you have an Windows 8.1 OS  - I have checked this device on the Digitus website  (  http://www.digitus.info/windows/en/products/accessories/adapter-and-converter/r-usb-serial-adapter-u... ) and it appears that it supports only up to Windows 7.

 

 

 

Regards, 

0 Kudos
Message 2 of 3
(4,655 Views)

Thank you for reply,

 

I found what was causing the error. It was because the converter im using does use DB9 type plug BUT the only signals that are coming out of it are RS485 A and RS485 B (half duplex), just two pins + GND (the TxA TxB RxA RxB are connected inside the case) so loopback plug was completly wrong.

 

In the end i had to find a second USB to RS485 converter, plug them both at once to computer and connect each others A and B signals and when in one terminal window i sent "test" the other terminal window from other converter recieved "test"

 

The one weird thing i noticed is that when i sent "test" (send as ascii) in one terminal (one USB to RS485) converter when it sent that msg it recieved null character and the second terminal window (another RS485 converter) recieved "test" but ended with a null character aswell. I dont know if its normal but ill try to ask around somewhere esle, since its less and less releated to labview.

 

ps. The converter i used is based on FT232R(L) chip. The manufacturers website FTDI have up to date drivers for windows 8 and 8.1 thas where i got them from

0 Kudos
Message 3 of 3
(4,626 Views)