Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

PCI-GPIB is missing in DM 2000&XP why?

I tried to install NI PCI-GPIB card both on an Win2000 sys and on Win XP sys
I tried 3 different PC's
I tried 2 different card
driver ver 2.2 , 2.3 and 1.6
all tries result with nothing
The PnP card wasn't recognized by the system as it should
when I tried to install it manually (add hardware ....) I could see the NI logo in the Device Manager
I could also see the PCI-GPIB card there but without the "resource" page (just "general" and "Driver" pages were there)
When trying to check with start up wizard just the first test pass (before manual installation) and just 2 out of 3 after.
Any suggestion?
thx
0 Kudos
Message 1 of 4
(3,072 Views)
Usually when the PCI-GPIB installation fails the third verification test in "Getting Started Wizard", there is a resource conflict (IRQ conflict)in the system. But I have never seen the "Resources" tab not showing up in Device Manager. Can you try delete the hardware from Device Manager and scan for it again and see if that will at least bring up the Resources tab? If there is a resource conflict, we need to see it in Device Manager.

Also, making sure you have a PCI-GPIB card, not an old AT-GPIB card. You can post the serial number of the card here so I can check it for you.
0 Kudos
Message 2 of 4
(3,063 Views)
Thx for your reply

I did try to del the card and let the sys look for it (scan)for few times but again nothing
As I wrote I tried it on 3 different PC's . Today I tried it on 4th one...and nothing .

On the card it is written "PCI-GPIB" so no mistake here probably.

I erased every thing (drivers) and install a ver 1.6 only and test it with the two card and nothing...
Then I install 3rd card from 2001 (minor changes on the layout)and every thing works fine.
PnP works great. No conflict simple configuration. Installation of the controlling software and the
hole system is working

now I need to see what is wrong with the two other cards.

Any clue ?
0 Kudos
Message 3 of 4
(3,059 Views)
Hello,

Driver v1.6 may not fully work with the newest PCI-GPIB cards since there were minor changes in the boards (as you can see the difference). Load the latest version (2.3) of the driver from here: www.ni.com/support/gpib/versions.htm, then make sure that your old 2001 card works. If so, then remove it and try the other 2 cards. Let us know the results here.

I initially thought that you may have a bad card, but if 2 of them are failing then that's rather odd. Where did you get these cards? Are they new? Have they worked in other PC's?

Scott B.
GPIB Software
National Instruments
0 Kudos
Message 4 of 4
(3,044 Views)